summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/gzip/gzip_1.3.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/gzip/gzip_1.3.12.bb')
-rw-r--r--meta/recipes-extended/gzip/gzip_1.3.12.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-extended/gzip/gzip_1.3.12.bb b/meta/recipes-extended/gzip/gzip_1.3.12.bb
new file mode 100644
index 0000000000..c111e2e24d
--- /dev/null
+++ b/meta/recipes-extended/gzip/gzip_1.3.12.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Standard GNU compressor"
2HOMEPAGE = "http://www.gnu.org/software/gzip"
3SECTION = "base"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7 file://gzip.h;endline=22;md5=c0934ad1900d927f86556153d4c76d23 \
8 file://lzw.h;endline=19;md5=c273e09a02edd9801cc74d39683049e9 "
9
10SRC_URI = "${GNU_MIRROR}/gzip/gzip-${PV}.tar.gz \
11 file://m4-extensions-fix.patch;patch=1 \
12 file://dup-def-fix.patch;patch=1"
13
14PR = "r0"
15
16inherit autotools
17
18do_install () {
19 autotools_do_install
20 # move files into /bin (FHS)
21 install -d ${D}${base_bindir}
22 mv ${D}${bindir}/gunzip ${D}${base_bindir}/gunzip.${PN}
23 mv ${D}${bindir}/gzip ${D}${base_bindir}/gzip.${PN}
24 mv ${D}${bindir}/zcat ${D}${base_bindir}/zcat.${PN}
25}
26
27pkg_postinst_${PN} () {
28 update-alternatives --install ${base_bindir}/gunzip gunzip gunzip.${PN} 100
29 update-alternatives --install ${base_bindir}/gzip gzip gzip.${PN} 100
30 update-alternatives --install ${base_bindir}/zcat zcat zcat.${PN} 100
31}
32
33pkg_prerm_${PN} () {
34 update-alternatives --remove gunzip gunzip.${PN}
35 update-alternatives --remove gzip gzip.${PN}
36 update-alternatives --remove zcat zcat.${PN}
37}
38
39BBCLASSEXTEND = "native"