summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/groff/groff_1.22.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/groff/groff_1.22.2.bb')
-rw-r--r--meta/recipes-extended/groff/groff_1.22.2.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/recipes-extended/groff/groff_1.22.2.bb b/meta/recipes-extended/groff/groff_1.22.2.bb
new file mode 100644
index 0000000000..6c6926ff62
--- /dev/null
+++ b/meta/recipes-extended/groff/groff_1.22.2.bb
@@ -0,0 +1,68 @@
1SUMMARY = "GNU Troff software"
2DESCRIPTION = "The groff (GNU troff) software is a typesetting package which reads plain text mixed with \
3formatting commands and produces formatted output."
4SECTION = "base"
5HOMEPAGE = "ftp://ftp.gnu.org/gnu/groff/"
6LICENSE = "GPLv3"
7PR = "r1"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "${GNU_MIRROR}/groff/groff-${PV}.tar.gz \
12 file://groff-1.22.2-correct-man.local-install-path.patch \
13"
14
15SRC_URI[md5sum] = "9f4cd592a5efc7e36481d8d8d8af6d16"
16SRC_URI[sha256sum] = "380864dac4772e0c0d7b1282d25d0c5fd7f63baf45c87c4657afed22a13d2076"
17
18DEPENDS = "groff-native"
19DEPENDS_class-native = ""
20
21inherit autotools texinfo
22
23EXTRA_OECONF = "--without-x"
24PARALLEL_MAKE = ""
25
26do_configure_prepend() {
27 if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
28 sed -i \
29 -e '/^GROFFBIN=/s:=.*:=${STAGING_BINDIR_NATIVE}/groff:' \
30 -e '/^TROFFBIN=/s:=.*:=${STAGING_BINDIR_NATIVE}/troff:' \
31 -e '/^GROFF_BIN_PATH=/s:=.*:=${STAGING_BINDIR_NATIVE}:' \
32 -e '/^GROFF_BIN_DIR=/s:=.*:=${STAGING_BINDIR_NATIVE}:' \
33 ${S}/contrib/*/Makefile.sub \
34 ${S}/doc/Makefile.in \
35 ${S}/doc/Makefile.sub
36 fi
37}
38
39do_configure_append() {
40 # generate gnulib configure script
41 olddir=`pwd`
42 cd ${S}/src/libs/gnulib/
43 ACLOCAL="$ACLOCAL" autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || bbfatal "autoreconf execution failed."
44 cd ${olddir}
45}
46
47do_install_append() {
48 # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
49 # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
50 for i in afmtodit mmroff gropdf pdfmom; do
51 if [ -f ${D}${bindir}/$i ]; then
52 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/$i
53 fi
54 done
55}
56
57do_install_append_class-native() {
58 create_cmdline_wrapper ${D}/${bindir}/groff \
59 -F${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/font \
60 -M${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/tmac
61}
62
63FILES_${PN} += "${libdir}/${BPN}/site-tmac \
64 ${libdir}/${BPN}/groffer/"
65
66RDEPENDS_${PN} = " sed"
67
68BBCLASSEXTEND = "native"