summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/groff/groff_1.20.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/groff/groff_1.20.1.bb')
-rw-r--r--meta/recipes-extended/groff/groff_1.20.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/groff/groff_1.20.1.bb b/meta/recipes-extended/groff/groff_1.20.1.bb
new file mode 100644
index 0000000000..e0e198f576
--- /dev/null
+++ b/meta/recipes-extended/groff/groff_1.20.1.bb
@@ -0,0 +1,36 @@
1SUMMARY = "GNU Troff software"
2DESCRIPTION = "The groff (GNU troff) software is a typesetting package which reads plain text mixed with \
3formatting commands and produces formatted output."
4SECTION = "base"
5HOMEPAGE = "ftp://ftp.gnu.org/gnu/groff/"
6LICENSE = "GPLv2"
7PR = "r0"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "${GNU_MIRROR}/groff/groff-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "48fa768dd6fdeb7968041dd5ae8e2b02"
14SRC_URI[sha256sum] = "b645878135cb620c6c417c5601bfe96172245af12045540d7344938b4c2cd805"
15
16DEPENDS = "groff-native"
17DEPENDS_virtclass-native = ""
18
19inherit autotools
20
21PARALLEL_MAKE = ""
22
23do_configure_prepend() {
24 if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
25 sed -i \
26 -e '/^GROFFBIN=/s:=.*:=${STAGING_BINDIR_NATIVE}/groff:' \
27 -e '/^TROFFBIN=/s:=.*:=${STAGING_BINDIR_NATIVE}/troff:' \
28 -e '/^GROFF_BIN_PATH=/s:=.*:=${STAGING_BINDIR_NATIVE}:' \
29 -e '/^GROFF_BIN_DIR=/s:=.*:=${STAGING_BINDIR_NATIVE}:' \
30 ${S}/contrib/*/Makefile.sub \
31 ${S}/doc/Makefile.in \
32 ${S}/doc/Makefile.sub
33 fi
34}
35
36BBCLASSEXTEND = "native"