diff options
Diffstat (limited to 'meta/recipes-extended/grep/grep_3.1.bb')
-rw-r--r-- | meta/recipes-extended/grep/grep_3.1.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_3.1.bb b/meta/recipes-extended/grep/grep_3.1.bb new file mode 100644 index 0000000000..05b6b93949 --- /dev/null +++ b/meta/recipes-extended/grep/grep_3.1.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | SUMMARY = "GNU grep utility" | ||
2 | HOMEPAGE = "http://savannah.gnu.org/projects/grep/" | ||
3 | BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep" | ||
4 | SECTION = "console/utils" | ||
5 | LICENSE = "GPLv3" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee" | ||
7 | |||
8 | SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz \ | ||
9 | file://0001-Unset-need_charset_alias-when-building-for-musl.patch \ | ||
10 | " | ||
11 | |||
12 | SRC_URI[md5sum] = "feca7b3e7c7f4aab2b42ecbfc513b070" | ||
13 | SRC_URI[sha256sum] = "db625c7ab3bb3ee757b3926a5cfa8d9e1c3991ad24707a83dde8a5ef2bf7a07e" | ||
14 | |||
15 | inherit autotools gettext texinfo pkgconfig | ||
16 | |||
17 | EXTRA_OECONF = "--disable-perl-regexp" | ||
18 | |||
19 | # Fix "Argument list too long" error when len(TMPDIR) = 410 | ||
20 | acpaths = "-I ./m4" | ||
21 | |||
22 | do_configure_prepend () { | ||
23 | rm -f ${S}/m4/init.m4 | ||
24 | } | ||
25 | |||
26 | do_install () { | ||
27 | autotools_do_install | ||
28 | if [ "${base_bindir}" != "${bindir}" ]; then | ||
29 | install -d ${D}${base_bindir} | ||
30 | mv ${D}${bindir}/grep ${D}${base_bindir}/grep | ||
31 | mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep | ||
32 | mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep | ||
33 | rmdir ${D}${bindir}/ | ||
34 | fi | ||
35 | } | ||
36 | |||
37 | inherit update-alternatives | ||
38 | |||
39 | ALTERNATIVE_PRIORITY = "100" | ||
40 | |||
41 | ALTERNATIVE_${PN} = "grep egrep fgrep" | ||
42 | ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep" | ||
43 | ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep" | ||
44 | ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep" | ||
45 | |||
46 | export CONFIG_SHELL="/bin/sh" | ||