summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.9.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.9.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta/recipes-extended/grep/grep_2.9.bb b/meta/recipes-extended/grep/grep_2.9.bb
deleted file mode 100644
index f936611062..0000000000
--- a/meta/recipes-extended/grep/grep_2.9.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1SUMMARY = "GNU grep utility"
2DESCRIPTION = "GNU grep utility"
3HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
4BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
5SECTION = "console/utils"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
8
9PR = "r2"
10
11SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "03e3451a38b0d615cb113cbeaf252dc0"
14SRC_URI[sha256sum] = "e9118eac72ecc71191725a7566361ab7643edfd3364869a47b78dc934a357970"
15
16inherit autotools gettext
17
18EXTRA_OECONF = "--disable-perl-regexp"
19
20do_configure_prepend () {
21 rm -f ${S}/m4/init.m4
22}
23
24do_install () {
25 autotools_do_install
26 install -d ${D}${base_bindir}
27 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
28 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
29 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
30 rmdir ${D}${bindir}/
31}
32
33inherit update-alternatives
34
35ALTERNATIVE_PRIORITY = "100"
36
37ALTERNATIVE_${PN} = "grep egrep fgrep"
38ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
39ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
40ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
41