summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.8.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.8.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_2.8.bb b/meta/recipes-extended/grep/grep_2.8.bb
new file mode 100644
index 0000000000..7e58ff8539
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_2.8.bb
@@ -0,0 +1,42 @@
1DESCRIPTION = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5PRIORITY = "optional"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
8
9PR = "r0"
10
11SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "cb2dfc502c5afc7a4a6e5f6cefd6850e"
14SRC_URI[sha256sum] = "da48d0e20bceaacc7d05bfcbccb34c3dee0c50bd7e80de5222fd5e319809af27"
15
16inherit autotools gettext
17
18EXTRA_OECONF = "--disable-perl-regexp"
19
20do_configure_prepend () {
21 rm -f ${S}/m4/init.m4
22}
23
24do_install () {
25 autotools_do_install
26 install -d ${D}${base_bindir}
27 mv ${D}${bindir}/grep ${D}${base_bindir}/grep.${PN}
28 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep.${PN}
29 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep.${PN}
30}
31
32pkg_postinst_${PN} () {
33 update-alternatives --install ${base_bindir}/grep grep grep.${PN} 100
34 update-alternatives --install ${base_bindir}/egrep egrep egrep.${PN} 100
35 update-alternatives --install ${base_bindir}/fgrep fgrep fgrep.${PN} 100
36}
37
38pkg_prerm_${PN} () {
39 update-alternatives --remove grep grep.${PN}
40 update-alternatives --remove egrep egrep.${PN}
41 update-alternatives --remove fgrep fgrep.${PN}
42}