summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.5.1a.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.5.1a.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.5.1a.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_2.5.1a.bb b/meta/recipes-extended/grep/grep_2.5.1a.bb
new file mode 100644
index 0000000000..1ce112e43d
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_2.5.1a.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Pattern matching utilities"
2DESCRIPTION = "The GNU versions of commonly used grep utilities. The grep command searches one or more input \
3files for lines containing a match to a specified pattern."
4SECTION = "console/utils"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
7
8PR = "r2"
9
10SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.bz2 \
11 file://uclibc-fix.patch \
12 file://grep_fix_for_automake-1.12.patch \
13 file://gettext.patch \
14 file://fix64-int-to-pointer.patch \
15 file://Makevars \
16 file://grep-CVE-2012-5667.patch \
17 file://fix-for-texinfo-5.1.patch \
18 "
19
20SRC_URI[md5sum] = "52202fe462770fa6be1bb667bd6cf30c"
21SRC_URI[sha256sum] = "38c8a2bb9223d1fb1b10bdd607cf44830afc92fd451ac4cd07619bf92bdd3132"
22
23inherit autotools gettext texinfo
24
25EXTRA_OECONF = "--disable-perl-regexp --disable-ncurses"
26
27CFLAGS += "-D PROTOTYPES"
28do_configure_prepend () {
29 rm -f ${S}/m4/init.m4
30 cp -f ${WORKDIR}/Makevars ${S}/po/
31}
32
33do_install () {
34 autotools_do_install
35 install -d ${D}${base_bindir}
36 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
37 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
38 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
39 rmdir ${D}${bindir}/
40}
41
42inherit update-alternatives
43
44ALTERNATIVE_PRIORITY = "100"
45
46ALTERNATIVE_${PN} = "grep egrep fgrep"
47ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
48ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
49ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
50
51export CONFIG_SHELL="/bin/sh"