summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.5.1a.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.5.1a.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.5.1a.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_2.5.1a.bb b/meta/recipes-extended/grep/grep_2.5.1a.bb
new file mode 100644
index 0000000000..d50d5a374e
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_2.5.1a.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "grep GNU utility"
2SECTION = "console/utils"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5
6PR = "r1"
7
8SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.bz2 \
9 file://uclibc-fix.patch"
10
11SRC_URI[md5sum] = "52202fe462770fa6be1bb667bd6cf30c"
12SRC_URI[sha256sum] = "38c8a2bb9223d1fb1b10bdd607cf44830afc92fd451ac4cd07619bf92bdd3132"
13
14inherit autotools gettext
15
16EXTRA_OECONF = "--disable-perl-regexp --disable-ncurses"
17
18do_configure_prepend () {
19 rm -f ${S}/m4/init.m4
20}
21
22do_install () {
23 autotools_do_install
24 install -d ${D}${base_bindir}
25 mv ${D}${bindir}/grep ${D}${base_bindir}/grep.${PN}
26 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep.${PN}
27 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep.${PN}
28}
29
30pkg_postinst_${PN} () {
31 update-alternatives --install ${base_bindir}/grep grep grep.${PN} 100
32 update-alternatives --install ${base_bindir}/egrep egrep egrep.${PN} 100
33 update-alternatives --install ${base_bindir}/fgrep fgrep fgrep.${PN} 100
34}
35
36pkg_prerm_${PN} () {
37 update-alternatives --remove grep grep.${PN}
38 update-alternatives --remove egrep egrep.${PN}
39 update-alternatives --remove fgrep fgrep.${PN}
40}