summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.5.1a.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.5.1a.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.5.1a.bb56
1 files changed, 0 insertions, 56 deletions
diff --git a/meta/recipes-extended/grep/grep_2.5.1a.bb b/meta/recipes-extended/grep/grep_2.5.1a.bb
deleted file mode 100644
index 5a2da28327..0000000000
--- a/meta/recipes-extended/grep/grep_2.5.1a.bb
+++ /dev/null
@@ -1,56 +0,0 @@
1SUMMARY = "Pattern matching utilities"
2DESCRIPTION = "The GNU versions of commonly used grep utilities. The grep command searches one or more input \
3files for lines containing a match to a specified pattern."
4SECTION = "console/utils"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
7
8PR = "r2"
9
10SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.bz2 \
11 file://uclibc-fix.patch \
12 file://grep_fix_for_automake-1.12.patch \
13 file://gettext.patch \
14 file://fix64-int-to-pointer.patch \
15 file://Makevars \
16 file://grep-CVE-2012-5667.patch \
17 file://fix-for-texinfo-5.1.patch \
18 file://grep-egrep-fgrep-Fix-LSB-NG-cases.patch \
19 "
20
21SRC_URI[md5sum] = "52202fe462770fa6be1bb667bd6cf30c"
22SRC_URI[sha256sum] = "38c8a2bb9223d1fb1b10bdd607cf44830afc92fd451ac4cd07619bf92bdd3132"
23
24inherit autotools gettext texinfo
25
26EXTRA_OECONF_INCLUDED_REGEX = "--without-included-regex"
27EXTRA_OECONF_INCLUDED_REGEX_libc-musl = "--with-included-regex"
28
29EXTRA_OECONF = "--disable-perl-regexp \
30 ${EXTRA_OECONF_INCLUDED_REGEX}"
31
32CFLAGS += "-D PROTOTYPES"
33do_configure_prepend () {
34 rm -f ${S}/m4/init.m4
35 cp -f ${WORKDIR}/Makevars ${S}/po/
36}
37
38do_install () {
39 autotools_do_install
40 install -d ${D}${base_bindir}
41 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
42 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
43 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
44 rmdir ${D}${bindir}/
45}
46
47inherit update-alternatives
48
49ALTERNATIVE_PRIORITY = "100"
50
51ALTERNATIVE_${PN} = "grep egrep fgrep"
52ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
53ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
54ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
55
56export CONFIG_SHELL="/bin/sh"