summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.22.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.22.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_2.22.bb b/meta/recipes-extended/grep/grep_2.22.bb
new file mode 100644
index 0000000000..8092a0f057
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_2.22.bb
@@ -0,0 +1,43 @@
1SUMMARY = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
7
8SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz \
9 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
10 "
11
12SRC_URI[md5sum] = "e1015e951a49a82b02e38891026ef5df"
13SRC_URI[sha256sum] = "ca91d22f017bfcb503d4bc3b44295491c89a33a3df0c3d8b8614f2d3831836eb"
14
15inherit autotools gettext texinfo
16
17EXTRA_OECONF = "--disable-perl-regexp"
18
19do_configure_prepend () {
20 rm -f ${S}/m4/init.m4
21}
22
23do_install () {
24 autotools_do_install
25 if [ "${base_bindir}" != "${bindir}" ]; then
26 install -d ${D}${base_bindir}
27 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
28 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
29 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
30 rmdir ${D}${bindir}/
31 fi
32}
33
34inherit update-alternatives
35
36ALTERNATIVE_PRIORITY = "100"
37
38ALTERNATIVE_${PN} = "grep egrep fgrep"
39ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
40ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
41ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
42
43export CONFIG_SHELL="/bin/sh"