summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.19.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.19.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_2.19.bb b/meta/recipes-extended/grep/grep_2.19.bb
new file mode 100644
index 0000000000..d60ce5e389
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_2.19.bb
@@ -0,0 +1,41 @@
1SUMMARY = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
7
8SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz \
9 file://grep2.19-CVE-2015-1345.patch \
10 "
11
12SRC_URI[md5sum] = "ac732142227d9fe9567d71301e127979"
13SRC_URI[sha256sum] = "6388295be48cfcaf7665d9cd3914e6625ea000e9414132bfefd45cf1d8eec34d"
14
15inherit autotools gettext texinfo
16
17EXTRA_OECONF = "--disable-perl-regexp"
18
19do_configure_prepend () {
20 rm -f ${S}/m4/init.m4
21}
22
23do_install () {
24 autotools_do_install
25 install -d ${D}${base_bindir}
26 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
27 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
28 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
29 rmdir ${D}${bindir}/
30}
31
32inherit update-alternatives
33
34ALTERNATIVE_PRIORITY = "100"
35
36ALTERNATIVE_${PN} = "grep egrep fgrep"
37ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
38ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
39ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
40
41export CONFIG_SHELL="/bin/sh"