summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.18.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.18.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_2.18.bb b/meta/recipes-extended/grep/grep_2.18.bb
new file mode 100644
index 0000000000..5ffeaf0d99
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_2.18.bb
@@ -0,0 +1,38 @@
1SUMMARY = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
7
8SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz"
9
10SRC_URI[md5sum] = "7439f8266f50844b56cc3e2721606541"
11SRC_URI[sha256sum] = "e6436e5077fa1497feccc8feaabd3f507b172369bf120fbc9e4874bba81be720"
12
13inherit autotools gettext
14
15EXTRA_OECONF = "--disable-perl-regexp"
16
17do_configure_prepend () {
18 rm -f ${S}/m4/init.m4
19}
20
21do_install () {
22 autotools_do_install
23 install -d ${D}${base_bindir}
24 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
25 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
26 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
27 rmdir ${D}${bindir}/
28}
29
30inherit update-alternatives
31
32ALTERNATIVE_PRIORITY = "100"
33
34ALTERNATIVE_${PN} = "grep egrep fgrep"
35ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
36ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
37ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
38