summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.15.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.15.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_2.15.bb b/meta/recipes-extended/grep/grep_2.15.bb
new file mode 100644
index 0000000000..b6aa882ed1
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_2.15.bb
@@ -0,0 +1,39 @@
1SUMMARY = "GNU grep utility"
2DESCRIPTION = "GNU grep utility"
3HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
4BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
5SECTION = "console/utils"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
8
9SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz"
10
11SRC_URI[md5sum] = "8cab8ca52bcae735af40278423c7c942"
12SRC_URI[sha256sum] = "bf5a834e587974c8c64e71b35b9e75cd21c7ff253c0e7fbfb0a78be794965314"
13
14inherit autotools gettext
15
16EXTRA_OECONF = "--disable-perl-regexp"
17
18do_configure_prepend () {
19 rm -f ${S}/m4/init.m4
20}
21
22do_install () {
23 autotools_do_install
24 install -d ${D}${base_bindir}
25 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
26 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
27 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
28 rmdir ${D}${bindir}/
29}
30
31inherit update-alternatives
32
33ALTERNATIVE_PRIORITY = "100"
34
35ALTERNATIVE_${PN} = "grep egrep fgrep"
36ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
37ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
38ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
39