summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/go-examples/go-helloworld_0.1.bb')
-rw-r--r--meta/recipes-extended/go-examples/go-helloworld_0.1.bb15
1 files changed, 8 insertions, 7 deletions
diff --git a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
index d3f7525dc9..74f3520eae 100644
--- a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
+++ b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
@@ -1,21 +1,22 @@
1DESCRIPTION = "This is a simple example recipe that cross-compiles a Go program." 1SUMMARY = "This is a simple example recipe that cross-compiles a Go program."
2SECTION = "examples" 2SECTION = "examples"
3HOMEPAGE = "https://golang.org/" 3HOMEPAGE = "https://golang.org/"
4 4
5LICENSE = "MIT" 5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" 6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
7 7
8SRC_URI = "git://${GO_IMPORT}" 8SRC_URI = "git://go.googlesource.com/example;branch=master;protocol=https"
9SRCREV = "bcf50bfd7dcd8020c90965747d857ae42802e0c5" 9SRCREV = "32022caedd6a177a7717aa8680cbe179e1045935"
10UPSTREAM_CHECK_COMMITS = "1" 10UPSTREAM_CHECK_COMMITS = "1"
11 11
12GO_IMPORT = "github.com/golang/example" 12GO_IMPORT = "golang.org/x/example"
13GO_INSTALL = "${GO_IMPORT}/hello" 13GO_INSTALL = "${GO_IMPORT}/hello"
14GO_WORKDIR = "${GO_INSTALL}"
15 14
16inherit go-mod 15export GO111MODULE="off"
16
17inherit go
17 18
18# This is just to make clear where this example is 19# This is just to make clear where this example is
19do_install_append() { 20do_install:append() {
20 mv ${D}${bindir}/hello ${D}${bindir}/${BPN} 21 mv ${D}${bindir}/hello ${D}${bindir}/${BPN}
21} 22}