summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/go-examples/go-helloworld_0.1.bb')
-rw-r--r--meta/recipes-extended/go-examples/go-helloworld_0.1.bb24
1 files changed, 15 insertions, 9 deletions
diff --git a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
index 930c57df95..222fc9d349 100644
--- a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
+++ b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
@@ -1,13 +1,19 @@
1require go-examples.inc 1DESCRIPTION = "This is a simple example recipe that cross-compiles a Go program."
2SECTION = "examples"
3HOMEPAGE = "https://golang.org/"
2 4
3SRC_URI += " \ 5LICENSE = "MIT"
4 file://helloworld.go \ 6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5"
6 7
7do_compile() { 8SRC_URI = "git://${GO_IMPORT}"
8 go build helloworld.go 9SRCREV = "46695d81d1fae905a270fb7db8a4d11a334562fe"
9} 10
11GO_IMPORT = "github.com/golang/example"
12GO_INSTALL = "${GO_IMPORT}/hello"
13
14inherit go
10 15
11do_install() { 16# This is just to make clear where this example is
12 install -D -m 0755 ${S}/helloworld ${D}${bindir}/helloworld 17do_install_append() {
18 mv ${D}${bindir}/hello ${D}${bindir}/${BPN}
13} 19}