summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ghostscript/ghostscript_9.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/ghostscript/ghostscript_9.19.bb')
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.19.bb106
1 files changed, 106 insertions, 0 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.19.bb b/meta/recipes-extended/ghostscript/ghostscript_9.19.bb
new file mode 100644
index 0000000000..fe2016b15a
--- /dev/null
+++ b/meta/recipes-extended/ghostscript/ghostscript_9.19.bb
@@ -0,0 +1,106 @@
1SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter"
2DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \
3a back-end to a program such as ghostview, it can display PostScript and PDF \
4documents in an X11 environment. \
5\
6Furthermore, it can render PostScript and PDF files as graphics to be printed \
7on non-PostScript printers. Supported printers include common \
8dot-matrix, inkjet and laser models. \
9"
10HOMEPAGE = "http://www.ghostscript.com"
11SECTION = "console/utils"
12
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=b17cea54743435ab2a581c237bea294a"
15
16DEPENDS = "ghostscript-native tiff jpeg fontconfig cups libpng"
17DEPENDS_class-native = "libpng-native"
18
19UPSTREAM_CHECK_URI = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases"
20
21SRC_URI_BASE = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs919/${BPN}-${PV}.tar.gz \
22 file://ghostscript-9.15-parallel-make.patch \
23 file://ghostscript-9.16-Werror-return-type.patch \
24 file://png_mak.patch \
25 file://do-not-check-local-libpng-source.patch \
26"
27
28SRC_URI = "${SRC_URI_BASE} \
29 file://ghostscript-9.02-prevent_recompiling.patch \
30 file://ghostscript-9.02-genarch.patch \
31 file://objarch.h \
32 file://cups-no-gcrypt.patch \
33 "
34
35SRC_URI_class-native = "${SRC_URI_BASE} \
36 file://ghostscript-native-fix-disable-system-libtiff.patch \
37 file://base-genht.c-add-a-preprocessor-define-to-allow-fope.patch \
38 "
39
40SRC_URI[md5sum] = "c9682ce6b852f9197c69905a43928907"
41SRC_URI[sha256sum] = "cf3c0dce67db1557a87366969945f9c5235887989c0b585e037af366dc035989"
42
43EXTRA_OECONF = "--without-x --with-system-libtiff --without-jbig2dec \
44 --with-fontpath=${datadir}/fonts \
45 --without-libidn --with-cups-serverbin=${exec_prefix}/lib/cups \
46 --with-cups-datadir=${datadir}/cups \
47 "
48
49EXTRA_OECONF_append_mips = " --with-large_color_index=0"
50EXTRA_OECONF_append_mipsel = " --with-large_color_index=0"
51
52# Explicity disable libtiff, fontconfig,
53# freetype, cups for ghostscript-native
54EXTRA_OECONF_class-native = "--without-x --with-system-libtiff=no \
55 --without-jbig2dec \
56 --with-fontpath=${datadir}/fonts \
57 --without-libidn --disable-fontconfig \
58 --disable-freetype --disable-cups"
59
60# This has been fixed upstream but for now we need to subvert the check for time.h
61# http://bugs.ghostscript.com/show_bug.cgi?id=692443
62# http://bugs.ghostscript.com/show_bug.cgi?id=692426
63CFLAGS += "-DHAVE_SYS_TIME_H=1"
64BUILD_CFLAGS += "-DHAVE_SYS_TIME_H=1"
65
66inherit autotools
67
68do_configure_prepend () {
69 mkdir -p obj
70 mkdir -p soobj
71 if [ -e ${WORKDIR}/objarch.h ]; then
72 cp ${WORKDIR}/objarch.h obj/arch.h
73 fi
74}
75
76do_configure_append () {
77 # copy tools from the native ghostscript build
78 if [ "${PN}" != "ghostscript-native" ]; then
79 mkdir -p obj/aux soobj
80 for i in genarch genconf mkromfs echogs gendev genht; do
81 cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/aux/$i
82 done
83 fi
84}
85
86do_install_append () {
87 mkdir -p ${D}${datadir}/ghostscript/${PV}/
88 cp -r ${S}/Resource ${D}${datadir}/ghostscript/${PV}/
89 cp -r ${S}/iccprofiles ${D}${datadir}/ghostscript/${PV}/
90}
91
92do_compile_class-native () {
93 mkdir -p obj
94 for i in genarch genconf mkromfs echogs gendev genht; do
95 oe_runmake obj/aux/$i
96 done
97}
98
99do_install_class-native () {
100 install -d ${D}${bindir}/ghostscript-${PV}
101 for i in genarch genconf mkromfs echogs gendev genht; do
102 install -m 755 obj/aux/$i ${D}${bindir}/ghostscript-${PV}/$i
103 done
104}
105
106BBCLASSEXTEND = "native"