diff options
Diffstat (limited to 'meta/recipes-extended/ghostscript/ghostscript_9.15.bb')
-rw-r--r-- | meta/recipes-extended/ghostscript/ghostscript_9.15.bb | 106 |
1 files changed, 106 insertions, 0 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.15.bb b/meta/recipes-extended/ghostscript/ghostscript_9.15.bb new file mode 100644 index 0000000000..ee5483c20e --- /dev/null +++ b/meta/recipes-extended/ghostscript/ghostscript_9.15.bb | |||
@@ -0,0 +1,106 @@ | |||
1 | SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter" | ||
2 | DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \ | ||
3 | a back-end to a program such as ghostview, it can display PostScript and PDF \ | ||
4 | documents in an X11 environment. \ | ||
5 | \ | ||
6 | Furthermore, it can render PostScript and PDF files as graphics to be printed \ | ||
7 | on non-PostScript printers. Supported printers include common \ | ||
8 | dot-matrix, inkjet and laser models. \ | ||
9 | " | ||
10 | HOMEPAGE = "http://www.ghostscript.com" | ||
11 | SECTION = "console/utils" | ||
12 | |||
13 | LICENSE = "GPLv3" | ||
14 | LIC_FILES_CHKSUM = "file://LICENSE;md5=aad21ea85123608e6a0a58d54ee23567" | ||
15 | |||
16 | DEPENDS = "ghostscript-native tiff jpeg fontconfig cups" | ||
17 | DEPENDS_class-native = "" | ||
18 | |||
19 | SRC_URI_BASE = "http://downloads.ghostscript.com/public/ghostscript-${PV}.tar.gz" | ||
20 | |||
21 | SRC_URI = "${SRC_URI_BASE} \ | ||
22 | file://ghostscript-9.02-prevent_recompiling.patch \ | ||
23 | file://ghostscript-9.02-genarch.patch \ | ||
24 | file://objarch.h \ | ||
25 | file://ghostscript-9.02-parallel-make.patch \ | ||
26 | file://cups-no-gcrypt.patch \ | ||
27 | " | ||
28 | |||
29 | SRC_URI_class-native = "${SRC_URI_BASE} \ | ||
30 | file://ghostscript-native-fix-disable-system-libtiff.patch \ | ||
31 | file://base-genht.c-add-a-preprocessor-define-to-allow-fope.patch \ | ||
32 | " | ||
33 | |||
34 | SRC_URI[md5sum] = "5a78ab0990ff6ec3a103576bc8777c46" | ||
35 | SRC_URI[sha256sum] = "27f11e4fe5b89857ae745687281d1e4daf9681edc858a3f7e8e77ef09609777a" | ||
36 | |||
37 | EXTRA_OECONF = "--without-x --with-system-libtiff --without-jbig2dec \ | ||
38 | --with-fontpath=${datadir}/fonts \ | ||
39 | --without-libidn --with-cups-serverbin=${exec_prefix}/lib/cups \ | ||
40 | --with-cups-datadir=${datadir}/cups \ | ||
41 | ${@base_conditional('SITEINFO_ENDIANNESS', 'le', '--enable-little-endian', '--enable-big-endian', d)} \ | ||
42 | " | ||
43 | |||
44 | EXTRA_OECONF_append_mips = " --with-large_color_index=0" | ||
45 | EXTRA_OECONF_append_mipsel = " --with-large_color_index=0" | ||
46 | |||
47 | # Explicity disable libtiff, fontconfig, | ||
48 | # freetype, cups for ghostscript-native | ||
49 | EXTRA_OECONF_class-native = "--without-x --with-system-libtiff=no \ | ||
50 | --without-jbig2dec \ | ||
51 | --with-fontpath=${datadir}/fonts \ | ||
52 | --without-libidn --disable-fontconfig \ | ||
53 | --disable-freetype --disable-cups" | ||
54 | |||
55 | # This has been fixed upstream but for now we need to subvert the check for time.h | ||
56 | # http://bugs.ghostscript.com/show_bug.cgi?id=692443 | ||
57 | # http://bugs.ghostscript.com/show_bug.cgi?id=692426 | ||
58 | CFLAGS += "-DHAVE_SYS_TIME_H=1" | ||
59 | BUILD_CFLAGS += "-DHAVE_SYS_TIME_H=1" | ||
60 | |||
61 | inherit autotools-brokensep | ||
62 | |||
63 | do_configure_prepend () { | ||
64 | mkdir -p obj | ||
65 | mkdir -p soobj | ||
66 | if [ -e ${WORKDIR}/objarch.h ]; then | ||
67 | cp ${WORKDIR}/objarch.h obj/arch.h | ||
68 | fi | ||
69 | } | ||
70 | |||
71 | do_configure_append () { | ||
72 | # copy tools from the native ghostscript build | ||
73 | if [ "${PN}" != "ghostscript-native" ]; then | ||
74 | mkdir -p obj/aux soobj | ||
75 | for i in genarch genconf mkromfs echogs gendev genht; do | ||
76 | cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/aux/$i | ||
77 | done | ||
78 | fi | ||
79 | } | ||
80 | |||
81 | do_install_append () { | ||
82 | mkdir -p ${D}${datadir}/ghostscript/${PV}/ | ||
83 | cp -r Resource ${D}${datadir}/ghostscript/${PV}/ | ||
84 | cp -r iccprofiles ${D}${datadir}/ghostscript/${PV}/ | ||
85 | } | ||
86 | |||
87 | do_compile_class-native () { | ||
88 | mkdir -p obj | ||
89 | for i in genarch genconf mkromfs echogs gendev genht; do | ||
90 | oe_runmake obj/aux/$i | ||
91 | done | ||
92 | } | ||
93 | |||
94 | do_install_class-native () { | ||
95 | install -d ${D}${bindir}/ghostscript-${PV} | ||
96 | for i in genarch genconf mkromfs echogs gendev genht; do | ||
97 | install -m 755 obj/aux/$i ${D}${bindir}/ghostscript-${PV}/$i | ||
98 | done | ||
99 | } | ||
100 | |||
101 | BBCLASSEXTEND = "native" | ||
102 | |||
103 | # Ghostscript install tool 'instcopy' tries to remove already created | ||
104 | # directories during install and parallel make causes problems. | ||
105 | PARALLEL_MAKEINST="" | ||
106 | |||