summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ghostscript/ghostscript_9.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/ghostscript/ghostscript_9.14.bb')
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.14.bb104
1 files changed, 104 insertions, 0 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.14.bb b/meta/recipes-extended/ghostscript/ghostscript_9.14.bb
new file mode 100644
index 0000000000..73cebbc86a
--- /dev/null
+++ b/meta/recipes-extended/ghostscript/ghostscript_9.14.bb
@@ -0,0 +1,104 @@
1SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter"
2DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \
3a back-end to a program such as ghostview, it can display PostScript and PDF \
4documents in an X11 environment. \
5\
6Furthermore, it can render PostScript and PDF files as graphics to be printed \
7on non-PostScript printers. Supported printers include common \
8dot-matrix, inkjet and laser models. \
9\
10Package gsfonts contains a set of standard fonts for Ghostscript. \
11"
12HOMEPAGE = "http://www.ghostscript.com"
13SECTION = "console/utils"
14
15LICENSE = "GPLv3"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=aad21ea85123608e6a0a58d54ee23567"
17
18DEPENDS = "ghostscript-native tiff jpeg fontconfig cups"
19DEPENDS_class-native = ""
20
21SRC_URI_BASE = "http://downloads.ghostscript.com/public/ghostscript-${PV}.tar.gz"
22
23SRC_URI = "${SRC_URI_BASE} \
24 file://ghostscript-9.02-prevent_recompiling.patch \
25 file://ghostscript-9.02-genarch.patch \
26 file://objarch.h \
27 file://ghostscript-9.02-parallel-make.patch \
28 "
29
30SRC_URI_class-native = "${SRC_URI_BASE} \
31 file://ghostscript-native-fix-disable-system-libtiff.patch \
32 file://base-genht.c-add-a-preprocessor-define-to-allow-fope.patch \
33 "
34
35SRC_URI[md5sum] = "586494befb443363338c1b6379f13973"
36SRC_URI[sha256sum] = "ab2ba5ce11c8db396c9acf774a497182d7686d04670976cc3e690ada7db9f0d4"
37
38EXTRA_OECONF = "--without-x --with-system-libtiff --without-jbig2dec \
39 --with-fontpath=${datadir}/fonts \
40 --without-libidn --with-cups-serverbin=${exec_prefix}/lib/cups \
41 --with-cups-datadir=${datadir}/cups \
42 ${@base_conditional('SITEINFO_ENDIANNESS', 'le', '--enable-little-endian', '--enable-big-endian', d)} \
43 "
44
45# Explicity disable libtiff, fontconfig,
46# freetype, cups for ghostscript-native
47EXTRA_OECONF_class-native = "--without-x --with-system-libtiff=no \
48 --without-jbig2dec \
49 --with-fontpath=${datadir}/fonts \
50 --without-libidn --disable-fontconfig \
51 --disable-freetype --disable-cups"
52
53# This has been fixed upstream but for now we need to subvert the check for time.h
54# http://bugs.ghostscript.com/show_bug.cgi?id=692443
55# http://bugs.ghostscript.com/show_bug.cgi?id=692426
56CFLAGS += "-DHAVE_SYS_TIME_H=1"
57BUILD_CFLAGS += "-DHAVE_SYS_TIME_H=1"
58
59inherit autotools-brokensep
60
61do_configure_prepend () {
62 mkdir -p obj
63 mkdir -p soobj
64 if [ -e ${WORKDIR}/objarch.h ]; then
65 cp ${WORKDIR}/objarch.h obj/arch.h
66 fi
67}
68
69do_configure_append () {
70 # copy tools from the native ghostscript build
71 if [ "${PN}" != "ghostscript-native" ]; then
72 mkdir -p obj/aux soobj
73 for i in genarch genconf mkromfs echogs gendev genht; do
74 cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/aux/$i
75 done
76 fi
77}
78
79do_install_append () {
80 mkdir -p ${D}${datadir}/ghostscript/${PV}/
81 cp -r Resource ${D}${datadir}/ghostscript/${PV}/
82 cp -r iccprofiles ${D}${datadir}/ghostscript/${PV}/
83}
84
85do_compile_class-native () {
86 mkdir -p obj
87 for i in genarch genconf mkromfs echogs gendev genht; do
88 oe_runmake obj/aux/$i
89 done
90}
91
92do_install_class-native () {
93 install -d ${D}${bindir}/ghostscript-${PV}
94 for i in genarch genconf mkromfs echogs gendev genht; do
95 install -m 755 obj/aux/$i ${D}${bindir}/ghostscript-${PV}/$i
96 done
97}
98
99BBCLASSEXTEND = "native"
100
101# Ghostscript install tool 'instcopy' tries to remove already created
102# directories during install and parallel make causes problems.
103PARALLEL_MAKEINST=""
104