diff options
Diffstat (limited to 'meta/recipes-extended/ghostscript/ghostscript_9.02.bb')
-rw-r--r-- | meta/recipes-extended/ghostscript/ghostscript_9.02.bb | 67 |
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.02.bb b/meta/recipes-extended/ghostscript/ghostscript_9.02.bb new file mode 100644 index 0000000000..dcdedade10 --- /dev/null +++ b/meta/recipes-extended/ghostscript/ghostscript_9.02.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter" | ||
2 | DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \ | ||
3 | a back-end to a program such as ghostview, it can display PostScript and PDF \ | ||
4 | documents in an X11 environment. \ | ||
5 | \ | ||
6 | Furthermore, it can render PostScript and PDF files as graphics to be printed \ | ||
7 | on non-PostScript printers. Supported printers include common \ | ||
8 | dot-matrix, inkjet and laser models. \ | ||
9 | \ | ||
10 | Package gsfonts contains a set of standard fonts for Ghostscript. \ | ||
11 | " | ||
12 | HOMEPAGE = "http://www.ghostscript.com" | ||
13 | SECTION = "console/utils" | ||
14 | |||
15 | LICENSE = "GPLv3" | ||
16 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d151214b3131251dfc9d858593acbd24" | ||
17 | |||
18 | PR = "r0" | ||
19 | |||
20 | DEPENDS = "tiff ${PN}-native" | ||
21 | DEPENDS_virtclass-native = "" | ||
22 | |||
23 | SRC_URI = "http://downloads.ghostscript.com/public/ghostscript-${PV}.tar.bz2 \ | ||
24 | file://ghostscript-9.02-prevent_recompiling.patch \ | ||
25 | " | ||
26 | |||
27 | SRC_URI[md5sum] = "f67151444bd56a7904579fc75a083dd6" | ||
28 | SRC_URI[sha256sum] = "03ea2cad13a36f8f9160912012b79619a826e7148fada6d3531feb25409ee05a" | ||
29 | |||
30 | EXTRA_OECONF = "--with-system-libtiff --without-jbig2dec --without-jasper --x-includes=${STAGING_DIR_HOST}/usr/include/X11 --x-libraries=${STAGING_DIR_HOST}/usr/lib" | ||
31 | |||
32 | inherit autotools | ||
33 | |||
34 | do_configure () { | ||
35 | oe_runconf | ||
36 | |||
37 | # copy tools from the native ghostscript build | ||
38 | mkdir -p obj soobj | ||
39 | for i in genarch genconf mkromfs echogs gendev genht; do | ||
40 | cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/$i | ||
41 | cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i soobj/$i | ||
42 | done | ||
43 | } | ||
44 | |||
45 | python do_patch_virtclass-native () { | ||
46 | pass | ||
47 | } | ||
48 | |||
49 | do_configure_virtclass-native () { | ||
50 | oe_runconf | ||
51 | } | ||
52 | |||
53 | do_compile_virtclass-native () { | ||
54 | mkdir -p obj | ||
55 | for i in genarch genconf mkromfs echogs gendev genht; do | ||
56 | oe_runmake obj/$i | ||
57 | done | ||
58 | } | ||
59 | |||
60 | do_install_virtclass-native () { | ||
61 | install -d ${D}${bindir}/ghostscript-${PV} | ||
62 | for i in genarch genconf mkromfs echogs gendev genht; do | ||
63 | install -m 755 obj/$i ${D}${bindir}/ghostscript-${PV}/$i | ||
64 | done | ||
65 | } | ||
66 | |||
67 | BBCLASSEXTEND = "native" | ||