summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/gawk/gawk_4.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/gawk/gawk_4.0.2.bb')
-rw-r--r--meta/recipes-extended/gawk/gawk_4.0.2.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-extended/gawk/gawk_4.0.2.bb b/meta/recipes-extended/gawk/gawk_4.0.2.bb
new file mode 100644
index 0000000000..d5cc52d16d
--- /dev/null
+++ b/meta/recipes-extended/gawk/gawk_4.0.2.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "A program that you can use to select particular records in a \
2file and perform operations upon them."
3HOMEPAGE = "www.gnu.org/software/gawk"
4BUGTRACKER = "bug-gawk@gnu.org"
5SECTION = "console/utils"
6
7# gawk <= 3.1.5: GPLv2
8# gawk >= 3.1.6: GPLv3
9LICENSE = "GPLv3"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
11
12DEPENDS += "readline"
13
14RDEPENDS_gawk += "gawk-common"
15RDEPENDS_pgawk += "gawk-common"
16PR = "r0"
17
18SRC_URI = "${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz"
19
20SRC_URI[md5sum] = "4d505dc2c9f1eb3e9f8d6cac87d4bd1a"
21SRC_URI[sha256sum] = "6e0de117c3713aa8d7fa347fc9fd645b10038ae49d8cf947d8c1d51cbb76141a"
22
23inherit autotools gettext update-alternatives
24
25PACKAGES += "gawk-common pgawk dgawk"
26
27FILES_${PN} = "${bindir}/gawk* ${bindir}/igawk"
28FILES_gawk-common += "${datadir}/awk/* ${libexecdir}/awk/*"
29FILES_pgawk = "${bindir}/pgawk*"
30FILES_${PN}-dbg += "${libexecdir}/awk/.debug"
31FILES_dgawk = "${bindir}/dgawk*"
32
33ALTERNATIVE_${PN} = "awk"
34ALTERNATIVE_TARGET[awk] = "${bindir}/gawk"
35ALTERNATIVE_PRIORITY = "100"
36
37do_install_append() {
38 # remove the link since we don't package it
39 rm ${D}${bindir}/awk
40}