summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/gawk/gawk_3.1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/gawk/gawk_3.1.5.bb')
-rw-r--r--meta/recipes-extended/gawk/gawk_3.1.5.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-extended/gawk/gawk_3.1.5.bb b/meta/recipes-extended/gawk/gawk_3.1.5.bb
new file mode 100644
index 0000000000..c7af4a9b72
--- /dev/null
+++ b/meta/recipes-extended/gawk/gawk_3.1.5.bb
@@ -0,0 +1,42 @@
1SUMMARY = "GNU awk text processing utility"
2DESCRIPTION = "The GNU version of awk, a text processing utility. \
3Awk interprets a special-purpose programming language to do \
4quick and easy text pattern matching and reformatting jobs."
5HOMEPAGE = "www.gnu.org/software/gawk"
6BUGTRACKER = "bug-gawk@gnu.org"
7SECTION = "console/utils"
8
9# gawk <= 3.1.5: GPLv2
10# gawk >= 3.1.6: GPLv3
11LICENSE = "GPLv2"
12LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
13
14RDEPENDS_gawk += "gawk-common"
15RDEPENDS_pgawk += "gawk-common"
16PR = "r2"
17
18SRC_URI = "${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz \
19 file://gawk-3.1.5_fix_for_automake-1.12.patch"
20
21SRC_URI[md5sum] = "4760325489479cac17fe0114b8f62f30"
22SRC_URI[sha256sum] = "463dcb9d0ca398b1d4f5a332f6cd9cec56441265fca616f2ea1b44d459e9f0f8"
23
24inherit autotools gettext texinfo update-alternatives
25
26PACKAGES += "gawk-common pgawk"
27
28FILES_${PN} = "${bindir}/gawk* ${bindir}/igawk"
29FILES_gawk-common += "${datadir}/awk/* ${libdir}/gawk/awk/*"
30FILES_pgawk = "${bindir}/pgawk*"
31FILES_${PN}-dbg += "${libdir}/gawk/awk/.debug"
32
33ALTERNATIVE_${PN} = "awk"
34ALTERNATIVE_TARGET[awk] = "${bindir}/gawk"
35ALTERNATIVE_PRIORITY = "100"
36
37CFLAGS += "-D PROTOTYPES"
38
39do_install_append() {
40 # remove the link since we don't package it
41 rm ${D}${bindir}/awk
42}