summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/foomatic/foomatic-filters_4.0.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/foomatic/foomatic-filters_4.0.16.bb')
-rw-r--r--meta/recipes-extended/foomatic/foomatic-filters_4.0.16.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-extended/foomatic/foomatic-filters_4.0.16.bb b/meta/recipes-extended/foomatic/foomatic-filters_4.0.16.bb
new file mode 100644
index 0000000000..5f145b0681
--- /dev/null
+++ b/meta/recipes-extended/foomatic/foomatic-filters_4.0.16.bb
@@ -0,0 +1,39 @@
1SUMMARY = "OpenPrinting printer support - filters"
2DESCRIPTION = "Foomatic is a printer database designed to make it easier to set up \
3common printers for use with UNIX-like operating systems.\
4It provides the "glue" between a print spooler (like CUPS or lpr) and \
5the printer, by processing files sent to the printer. \
6 \
7This package consists of filters used by the printer spoolers \
8to convert the incoming PostScript data into the printer's native \
9format using a printer-specific, but spooler-independent PPD file. \
10"
11
12DEPENDS += "cups perl libxml2"
13PR = "r0"
14
15LICENSE = "GPLv2+"
16LIC_FILES_CHKSUM = "file://${WORKDIR}/foomatic-filters-${PV}/COPYING;md5=393a5ca445f6965873eca0259a17f833"
17
18SRC_URI = "http://www.openprinting.org/download/foomatic/foomatic-filters-${PV}.tar.gz"
19
20SRC_URI[md5sum] = "ec907d9ea17e03bccb91db66e9470586"
21SRC_URI[sha256sum] = "bedc61466c284c8ea0ae95c97d51a873411c6c55338e67831893772465f5434d"
22
23inherit autotools
24
25EXTRA_OECONF += "--disable-file-converter-check --with-file-converter=texttops"
26
27do_configure_prepend() {
28 export LIB_CUPS=${exec_prefix}/lib/cups # /usr/lib NOT libdir
29 export CUPS_BACKENDS=${exec_prefix}/lib/cups/backend # /usr/lib NOT libdir
30 export CUPS_FILTERS=${exec_prefix}/lib/cups/filter # /usr/lib NOT libdir
31 export CUPS_PPDS=${datadir}/cups/model
32}
33
34do_install_append_linuxstdbase() {
35 install -d ${D}${exec_prefix}/lib/cups/filter
36 ln -sf ${bindir}/foomatic-rip ${D}${exec_prefix}/lib/cups/filter
37}
38
39FILES_${PN} += "${exec_prefix}/lib/cups/ ${exec_prefix}/lib/ppr/"