summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_3.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_3.15.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_3.15.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_3.15.bb b/meta/recipes-extended/ethtool/ethtool_3.15.bb
new file mode 100644
index 0000000000..8cd10dfb43
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_3.15.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 file://ethtool-uint.patch \
13 "
14
15SRC_URI[md5sum] = "7e94dd958bcd639aad2e5a752e108b24"
16SRC_URI[sha256sum] = "562e3cc675cf5b1ac655cd060f032943a2502d4d59e5f278f02aae92562ba261"
17
18inherit autotools ptest
19RDEPENDS_${PN}-ptest += "make"
20
21do_compile_ptest() {
22 oe_runmake buildtest-TESTS
23}
24
25do_install_ptest () {
26 cp ${B}/Makefile ${D}${PTEST_PATH}
27 install ${B}/test-cmdline ${D}${PTEST_PATH}
28 install ${B}/test-features ${D}${PTEST_PATH}
29 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
30 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
31}