summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_3.12.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_3.12.1.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_3.12.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_3.12.1.bb b/meta/recipes-extended/ethtool/ethtool_3.12.1.bb
new file mode 100644
index 0000000000..19bca2fa0b
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_3.12.1.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest"
11
12SRC_URI[md5sum] = "5a1058efe8eb4f3473f5028967729078"
13SRC_URI[sha256sum] = "45190d70e5ce1b4d87def4f71fb5bf04f8a4f4dc5f9e0f38c49c16c462fb59d9"
14
15inherit autotools ptest
16RDEPENDS_${PN}-ptest += "make"
17
18do_compile_ptest() {
19 oe_runmake buildtest-TESTS
20}
21
22do_install_ptest () {
23 cp ${B}/Makefile ${D}${PTEST_PATH}
24 install ${B}/test-cmdline ${D}${PTEST_PATH}
25 install ${B}/test-features ${D}${PTEST_PATH}
26 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
27 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
28}