summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/diffutils/diffutils_3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/diffutils/diffutils_3.3.bb')
-rw-r--r--meta/recipes-extended/diffutils/diffutils_3.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-extended/diffutils/diffutils_3.3.bb b/meta/recipes-extended/diffutils/diffutils_3.3.bb
new file mode 100644
index 0000000000..a467f20aa4
--- /dev/null
+++ b/meta/recipes-extended/diffutils/diffutils_3.3.bb
@@ -0,0 +1,34 @@
1LICENSE = "GPLv3+"
2LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
3
4require diffutils.inc
5
6SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.xz \
7 file://run-ptest \
8"
9
10do_configure_prepend () {
11 # Need to remove gettext macros with weird mix of versions
12 for i in codeset.m4 gettext_gl.m4 intlmacosx.m4 inttypes-pri.m4 lib-ld_gl.m4 lib-prefix_gl.m4 po_gl.m4 ssize_t.m4 wchar_t.m4 wint_t.m4; do
13 rm -f ${S}/m4/$i
14 done
15}
16
17SRC_URI[md5sum] = "99180208ec2a82ce71f55b0d7389f1b3"
18SRC_URI[sha256sum] = "a25e89a8ab65fded1731e4186be1bb25cda967834b6df973599cdcd5abdfc19c"
19
20inherit ptest
21
22do_install_ptest() {
23 t=${D}${PTEST_PATH}
24 install -D ${S}/build-aux/test-driver $t/build-aux/test-driver
25 cp -r ${S}/tests $t/
26 install ${B}/tests/Makefile $t/tests/
27 sed -e 's|^Makefile:|_Makefile:|' \
28 -e 's|bash|sh|' \
29 -e 's|^top_srcdir = \(.*\)|top_srcdir = ..\/|' \
30 -e 's|^srcdir = \(.*\)|srcdir = .|' \
31 -e 's|"`$(built_programs)`"|diff|' \
32 -e 's|gawk|awk|g' \
33 -i $t/tests/Makefile
34}