diff options
Diffstat (limited to 'meta/recipes-extended/cronie/cronie_1.4.9.bb')
-rw-r--r-- | meta/recipes-extended/cronie/cronie_1.4.9.bb | 75 |
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-extended/cronie/cronie_1.4.9.bb b/meta/recipes-extended/cronie/cronie_1.4.9.bb new file mode 100644 index 0000000000..7db0381245 --- /dev/null +++ b/meta/recipes-extended/cronie/cronie_1.4.9.bb | |||
@@ -0,0 +1,75 @@ | |||
1 | SUMMARY = "Cron daemon for executing programs at set times" | ||
2 | DESCRIPTION = "Cronie contains the standard UNIX daemon crond that runs \ | ||
3 | specified programs at scheduled times and related tools. It is based on the \ | ||
4 | original cron and has security and configuration enhancements like the \ | ||
5 | ability to use pam and SELinux." | ||
6 | HOMEPAGE = "https://fedorahosted.org/cronie/" | ||
7 | BUGTRACKER = "mmaslano@redhat.com" | ||
8 | |||
9 | # Internet Systems Consortium License | ||
10 | LICENSE = "ISC & BSD" | ||
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=963ea0772a2adbdcd607a9b2ec320c11 \ | ||
12 | file://src/cron.h;endline=20;md5=b425c334265026177128353a142633b4 \ | ||
13 | file://src/popen.c;beginline=3;endline=31;md5=edd50742d8def712e9472dba353668a9" | ||
14 | |||
15 | SECTION = "utils" | ||
16 | |||
17 | DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" | ||
18 | RDEPENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_DEPS}', '', d)}" | ||
19 | PAM_DEPS = "libpam libpam-runtime pam-plugin-access pam-plugin-loginuid" | ||
20 | |||
21 | PR = "r0" | ||
22 | |||
23 | SRC_URI = "https://fedorahosted.org/releases/c/r/cronie/cronie-${PV}.tar.gz \ | ||
24 | file://crond.init \ | ||
25 | file://crontab \ | ||
26 | ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}" | ||
27 | |||
28 | PAM_SRC_URI = "file://crond_pam_config.patch" | ||
29 | |||
30 | |||
31 | SRC_URI[md5sum] = "9133195e5e6f824ef460f5ccc533f1b7" | ||
32 | SRC_URI[sha256sum] = "bd7f6f118460c452bd1217a24b80fd3c000425d3de28731b98354a81a2133e92" | ||
33 | |||
34 | inherit autotools update-rc.d useradd | ||
35 | |||
36 | EXTRA_OECONF += "\ | ||
37 | ${@base_contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)}" | ||
38 | |||
39 | INITSCRIPT_NAME = "crond" | ||
40 | INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ." | ||
41 | |||
42 | USERADD_PACKAGES = "${PN}" | ||
43 | GROUPADD_PARAM_${PN} = "crontab" | ||
44 | |||
45 | do_install_append () { | ||
46 | install -d ${D}${sysconfdir}/sysconfig/ | ||
47 | install -d ${D}${sysconfdir}/init.d/ | ||
48 | install -m 0644 ${S}/crond.sysconfig ${D}${sysconfdir}/sysconfig/crond | ||
49 | install -m 0755 ${WORKDIR}/crond.init ${D}${sysconfdir}/init.d/crond | ||
50 | |||
51 | # below are necessary for a complete cron environment | ||
52 | install -d ${D}${localstatedir}/spool/cron | ||
53 | install -m 0755 ${WORKDIR}/crontab ${D}${sysconfdir}/ | ||
54 | mkdir -p ${D}${sysconfdir}/cron.d | ||
55 | mkdir -p ${D}${sysconfdir}/cron.hourly | ||
56 | mkdir -p ${D}${sysconfdir}/cron.daily | ||
57 | mkdir -p ${D}${sysconfdir}/cron.weekly | ||
58 | mkdir -p ${D}${sysconfdir}/cron.monthly | ||
59 | touch ${D}${sysconfdir}/cron.deny | ||
60 | |||
61 | # below setting is necessary to allow normal user using crontab | ||
62 | |||
63 | # setgid for crontab binary | ||
64 | chown root:crontab ${D}${bindir}/crontab | ||
65 | chmod 2755 ${D}${bindir}/crontab | ||
66 | |||
67 | # allow 'crontab' group write to /var/spool/cron | ||
68 | chown root:crontab ${D}${localstatedir}/spool/cron | ||
69 | chmod 770 ${D}${localstatedir}/spool/cron | ||
70 | |||
71 | chmod 600 ${D}${sysconfdir}/crontab | ||
72 | } | ||
73 | |||
74 | FILES_${PN} += "${sysconfdir}/cron*" | ||
75 | |||