summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cronie/cronie_1.4.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/cronie/cronie_1.4.6.bb')
-rw-r--r--meta/recipes-extended/cronie/cronie_1.4.6.bb33
1 files changed, 31 insertions, 2 deletions
diff --git a/meta/recipes-extended/cronie/cronie_1.4.6.bb b/meta/recipes-extended/cronie/cronie_1.4.6.bb
index 6b4c64e3b1..09714c7f74 100644
--- a/meta/recipes-extended/cronie/cronie_1.4.6.bb
+++ b/meta/recipes-extended/cronie/cronie_1.4.6.bb
@@ -14,10 +14,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=963ea0772a2adbdcd607a9b2ec320c11 \
14 14
15SECTION = "utils" 15SECTION = "utils"
16 16
17PR = "r0" 17PR = "r1"
18 18
19SRC_URI = "https://fedorahosted.org/releases/c/r/cronie/cronie-${PV}.tar.gz \ 19SRC_URI = "https://fedorahosted.org/releases/c/r/cronie/cronie-${PV}.tar.gz \
20 file://crond.init" 20 file://crond.init \
21 file://crontab"
21 22
22SRC_URI[md5sum] = "968e3d3e7c8e1d0588d533883482d3fa" 23SRC_URI[md5sum] = "968e3d3e7c8e1d0588d533883482d3fa"
23SRC_URI[sha256sum] = "4435484c28a4452ee37db27182675660cdebf16d8956771b28c8a6f2e9c8048b" 24SRC_URI[sha256sum] = "4435484c28a4452ee37db27182675660cdebf16d8956771b28c8a6f2e9c8048b"
@@ -32,4 +33,32 @@ do_install_append () {
32 install -d ${D}${sysconfdir}/init.d/ 33 install -d ${D}${sysconfdir}/init.d/
33 install -m 0644 ${S}/crond.sysconfig ${D}${sysconfdir}/sysconfig/crond 34 install -m 0644 ${S}/crond.sysconfig ${D}${sysconfdir}/sysconfig/crond
34 install -m 0755 ${WORKDIR}/crond.init ${D}${sysconfdir}/init.d/crond 35 install -m 0755 ${WORKDIR}/crond.init ${D}${sysconfdir}/init.d/crond
36
37 # below are necessary for a complete cron environment
38 install -d ${D}${localstatedir}/spool/cron
39 install -m 0755 ${WORKDIR}/crontab ${D}${sysconfdir}/
40 mkdir -p ${D}${sysconfdir}/cron.d
41 mkdir -p ${D}${sysconfdir}/cron.hourly
42 mkdir -p ${D}${sysconfdir}/cron.daily
43 mkdir -p ${D}${sysconfdir}/cron.weekly
44 mkdir -p ${D}${sysconfdir}/cron.monthly
45}
46
47pkg_postinst_${PN} () {
48 if [ "x$D" != "x" ] ; then
49 exit 1
50 fi
51
52 # below setting is necessary to allow normal user using crontab
53
54 # add 'crontab' group and setgid for crontab binary
55 grep crontab /etc/group || addgroup crontab
56 chown root:crontab /usr/bin/crontab
57 chmod 2755 /usr/bin/crontab
58
59 # allow 'crontab' group write to /var/spool/cron
60 chown root:crontab /var/spool/cron
61 chmod 770 /var/spool/cron
62
63 chmod 600 /etc/crontab
35} 64}