summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cronie/cronie_1.4.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/cronie/cronie_1.4.6.bb')
-rw-r--r--meta/recipes-extended/cronie/cronie_1.4.6.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/cronie/cronie_1.4.6.bb b/meta/recipes-extended/cronie/cronie_1.4.6.bb
new file mode 100644
index 0000000000..e9b146b894
--- /dev/null
+++ b/meta/recipes-extended/cronie/cronie_1.4.6.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Cronie contains the standard UNIX daemon crond that runs \
2specified programs at scheduled times and related tools. It is based on the \
3original cron and has security and configuration enhancements like the \
4ability to use pam and SELinux."
5HOMEPAGE = "https://fedorahosted.org/cronie/"
6BUGTRACKER = "mmaslano@redhat.com"
7
8# Internet Systems Consortium License
9LICENSE = "ISC license & BSD"
10LIC_FILES_CHKSUM = "file://COPYING;md5=963ea0772a2adbdcd607a9b2ec320c11 \
11 file://src/cron.h;endline=20;md5=b425c334265026177128353a142633b4 \
12 file://src/popen.c;beginline=3;endline=31;md5=edd50742d8def712e9472dba353668a9"
13
14SECTION = "utils"
15
16PR = "r0"
17
18SRC_URI = "https://fedorahosted.org/releases/c/r/cronie/cronie-${PV}.tar.gz \
19 file://crond.init"
20
21inherit autotools update-rc.d
22
23INITSCRIPT_NAME = "crond"
24INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ."
25
26do_install_append () {
27 install -d ${D}${sysconfdir}/sysconfig/
28 install -d ${D}${sysconfdir}/init.d/
29 install -m 0644 ${S}/crond.sysconfig ${D}${sysconfdir}/sysconfig/crond
30 install -m 0755 ${WORKDIR}/crond.init ${D}${sysconfdir}/init.d/crond
31}