summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cronie/cronie_1.4.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/cronie/cronie_1.4.11.bb')
-rw-r--r--meta/recipes-extended/cronie/cronie_1.4.11.bb85
1 files changed, 85 insertions, 0 deletions
diff --git a/meta/recipes-extended/cronie/cronie_1.4.11.bb b/meta/recipes-extended/cronie/cronie_1.4.11.bb
new file mode 100644
index 0000000000..02234f6a36
--- /dev/null
+++ b/meta/recipes-extended/cronie/cronie_1.4.11.bb
@@ -0,0 +1,85 @@
1SUMMARY = "Cron daemon for executing programs at set times"
2DESCRIPTION = "Cronie contains the standard UNIX daemon crond that runs \
3specified programs at scheduled times and related tools. It is based on the \
4original cron and has security and configuration enhancements like the \
5ability to use pam and SELinux."
6HOMEPAGE = "https://fedorahosted.org/cronie/"
7BUGTRACKER = "mmaslano@redhat.com"
8
9# Internet Systems Consortium License
10LICENSE = "ISC & BSD"
11LIC_FILES_CHKSUM = "file://COPYING;md5=963ea0772a2adbdcd607a9b2ec320c11 \
12 file://src/cron.c;endline=20;md5=b425c334265026177128353a142633b4 \
13 file://src/popen.c;beginline=3;endline=31;md5=edd50742d8def712e9472dba353668a9"
14
15SECTION = "utils"
16
17
18SRC_URI = "https://fedorahosted.org/releases/c/r/cronie/cronie-${PV}.tar.gz \
19 file://fix-out-of-tree-build.patch \
20 file://crond.init \
21 file://crontab \
22 file://crond.service \
23 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
24
25PAM_SRC_URI = "file://crond_pam_config.patch"
26PAM_DEPS = "libpam libpam-runtime pam-plugin-access pam-plugin-loginuid"
27
28SRC_URI[md5sum] = "2ba645cf54de17f138ef70312843862f"
29SRC_URI[sha256sum] = "fd08084cedddbb42499f80ddb7f2158195c3555c2ff40ee11d4ece2f9864d7be"
30
31inherit autotools update-rc.d useradd systemd
32
33
34PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
35
36PACKAGECONFIG[audit] = "--with-audit,--without-audit,audit,"
37PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,${PAM_DEPS}"
38
39
40INITSCRIPT_NAME = "crond"
41INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ."
42
43USERADD_PACKAGES = "${PN}"
44GROUPADD_PARAM_${PN} = "--system crontab"
45
46SYSTEMD_SERVICE_${PN} = "crond.service"
47
48do_install_append () {
49 install -d ${D}${sysconfdir}/sysconfig/
50 install -d ${D}${sysconfdir}/init.d/
51 install -m 0644 ${S}/crond.sysconfig ${D}${sysconfdir}/sysconfig/crond
52 install -m 0755 ${WORKDIR}/crond.init ${D}${sysconfdir}/init.d/crond
53
54 # install systemd unit files
55 install -d ${D}${systemd_unitdir}/system
56 install -m 0644 ${WORKDIR}/crond.service ${D}${systemd_unitdir}/system
57 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
58 -e 's,@SBINDIR@,${sbindir},g' \
59 ${D}${systemd_unitdir}/system/crond.service
60
61 # below are necessary for a complete cron environment
62 install -d ${D}${localstatedir}/spool/cron
63 install -m 0755 ${WORKDIR}/crontab ${D}${sysconfdir}/
64 mkdir -p ${D}${sysconfdir}/cron.d
65 mkdir -p ${D}${sysconfdir}/cron.hourly
66 mkdir -p ${D}${sysconfdir}/cron.daily
67 mkdir -p ${D}${sysconfdir}/cron.weekly
68 mkdir -p ${D}${sysconfdir}/cron.monthly
69 touch ${D}${sysconfdir}/cron.deny
70
71 # below setting is necessary to allow normal user using crontab
72
73 # setgid for crontab binary
74 chown root:crontab ${D}${bindir}/crontab
75 chmod 2755 ${D}${bindir}/crontab
76
77 # allow 'crontab' group write to /var/spool/cron
78 chown root:crontab ${D}${localstatedir}/spool/cron
79 chmod 770 ${D}${localstatedir}/spool/cron
80
81 chmod 600 ${D}${sysconfdir}/crontab
82}
83
84FILES_${PN} += "${sysconfdir}/cron*"
85