summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cracklib/cracklib_2.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/cracklib/cracklib_2.9.2.bb')
-rw-r--r--meta/recipes-extended/cracklib/cracklib_2.9.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-extended/cracklib/cracklib_2.9.2.bb b/meta/recipes-extended/cracklib/cracklib_2.9.2.bb
new file mode 100644
index 0000000000..b66ca543b6
--- /dev/null
+++ b/meta/recipes-extended/cracklib/cracklib_2.9.2.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Password strength checker library"
2HOMEPAGE = "http://sourceforge.net/projects/cracklib"
3
4LICENSE = "LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06"
6
7DEPENDS = "cracklib-native zlib"
8DEPENDS_class-native = "zlib-native"
9
10EXTRA_OECONF = "--without-python --libdir=${base_libdir}"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/cracklib/cracklib-${PV}.tar.gz \
13 file://0001-packlib.c-support-dictionary-byte-order-dependent.patch \
14 file://0002-craklib-fix-testnum-and-teststr-failed.patch"
15
16SRC_URI[md5sum] = "559072fdfc095cdb763c4de3471a889e"
17SRC_URI[sha256sum] = "c1c899291d443e99d1aecfbc879e4ac9c0cbc265574f47b487842da11e9759f5"
18
19inherit autotools-brokensep gettext
20
21do_install_append_class-target() {
22 create-cracklib-dict -o ${D}${datadir}/cracklib/pw_dict ${D}${datadir}/cracklib/cracklib-small
23}
24
25BBCLASSEXTEND = "native nativesdk"