summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb')
-rw-r--r--meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb b/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
new file mode 100644
index 0000000000..d285c5047c
--- /dev/null
+++ b/meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb
@@ -0,0 +1,63 @@
1SUMMARY = "A system tool for maintaining the /etc/rc*.d hierarchy"
2DESCRIPTION = "Chkconfig is a basic system utility. It updates and queries runlevel \
3information for system services. Chkconfig manipulates the numerous \
4symbolic links in /etc/rc.d, to relieve system administrators of some \
5of the drudgery of manually editing the symbolic links."
6
7HOMEPAGE = "http://fedorahosted.org/releases/c/h/chkconfig"
8
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
11
12DEPENDS = "libnewt popt"
13PROVIDES += "virtual/update-alternatives"
14
15PR = "r7"
16
17SRC_URI = "http://fedorahosted.org/releases/c/h/chkconfig/${BPN}-${PV}.tar.bz2"
18
19SRC_URI[md5sum] = "c2039ca67f2749fe0c06ef7c6f8ee246"
20SRC_URI[sha256sum] = "18b497d25b2cada955c72810e45fcad8280d105f17cf45e2970f18271211de68"
21
22inherit gettext
23
24# Makefile uses RPM_OPT_FLAGS to construct CFLAGS
25#
26EXTRA_OEMAKE = "\
27 'RPM_OPT_FLAGS=${CFLAGS}' \
28 'LDFLAGS=${LDFLAGS}' \
29 'BINDIR=${base_sbindir}' \
30 'SBINDIR=${sbindir}' \
31 'MANDIR=${mandir}' \
32 'ALTDIR=${localstatedir}/lib/alternatives' \
33 'ALTDATADIR=${sysconfdir}/alternatives' \
34"
35
36do_unpack[postfuncs] += "obey_variables"
37do_unpack[vardeps] += "obey_variables"
38obey_variables () {
39 sed -i -e 's,/etc,${sysconfdir},; s,/lib/systemd,${base_libdir}/systemd,' leveldb.h
40 sed -i -e 's,/etc/alternatives,${sysconfdir}/alternatives,' \
41 -e 's,/var/lib/alternatives,${localstatedir}/lib/alternatives,' \
42 -e 's,/usr/share/locale,${datadir}/locale,' alternatives.c
43}
44
45do_install() {
46 oe_runmake 'DESTDIR=${D}' 'INSTALLNLSDIR=${D}${datadir}/locale' \
47 'BINDIR=${sbindir}' install
48 install -d ${D}${sysconfdir}/chkconfig.d
49}
50
51PACKAGES =+ "${PN}-alternatives ${PN}-alternatives-doc"
52SUMMARY_${PN}-alternatives = "Maintain symbolic links determining default commands"
53DESCRIPTION_${PN}-alternatives = "alternatives creates, removes, maintains and displays \
54information about the symbolic links comprising the alternatives system."
55SUMMARY_${PN}-alternatives-doc = "${SUMMARY_${PN}-alternatives} - Documentation files"
56DESCRIPTION_${PN}-alternatives-doc = "${DESCRIPTION_${PN}-alternatives} \
57This package contains documentation."
58RPROVIDES_${PN}-alternatives += "update-alternatives"
59RCONFLICTS_${PN}-alternatives = "update-alternatives-opkg update-alternatives-dpkg"
60FILES_${PN}-alternatives = "${sbindir}/alternatives ${sbindir}/update-alternatives \
61 ${sysconfdir}/alternatives ${localstatedir}/lib/alternatives"
62FILES_${PN}-alternatives-doc = "${mandir}/man8/alternatives.8 \
63 ${mandir}/man8/update-alternatives.8"