diff options
Diffstat (limited to 'meta/recipes-extended/bzip2/bzip2_1.0.5.bb')
-rw-r--r-- | meta/recipes-extended/bzip2/bzip2_1.0.5.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.5.bb b/meta/recipes-extended/bzip2/bzip2_1.0.5.bb new file mode 100644 index 0000000000..c6339c0676 --- /dev/null +++ b/meta/recipes-extended/bzip2/bzip2_1.0.5.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | DESCRIPTION = "Very high-quality data compression program." | ||
2 | HOMEPAGE = "http://www.bzip.org/" | ||
3 | SECTION = "console/utils" | ||
4 | LICENSE = "bzip2" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=8;endline=37;md5=40d9d1eb05736d1bfc86cfdd9106e6b2" | ||
6 | PR = "r2" | ||
7 | |||
8 | SRC_URI = "http://www.bzip.org/${PV}/${BPN}-${PV}.tar.gz \ | ||
9 | file://configure.ac \ | ||
10 | file://Makefile.am" | ||
11 | |||
12 | CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64" | ||
13 | |||
14 | inherit autotools | ||
15 | |||
16 | do_configure_prepend () { | ||
17 | cp ${WORKDIR}/configure.ac ${S}/ | ||
18 | cp ${WORKDIR}/Makefile.am ${S}/ | ||
19 | cp ${STAGING_DATADIR_NATIVE}/automake*/install-sh ${S}/ | ||
20 | } | ||
21 | |||
22 | do_install_append () { | ||
23 | if [ "${BUILD_ARCH}" != "${HOST_ARCH}" ]; then | ||
24 | mv ${D}${bindir}/bunzip2 ${D}${bindir}/bunzip2.${PN} | ||
25 | mv ${D}${bindir}/bzcat ${D}${bindir}/bzcat.${PN} | ||
26 | fi | ||
27 | } | ||
28 | |||
29 | pkg_postinst_${PN} () { | ||
30 | update-alternatives --install ${bindir}/bunzip2 bunzip2 bunzip2.${PN} 100 | ||
31 | update-alternatives --install ${bindir}/bzcat bzcat bzcat.${PN} 100 | ||
32 | } | ||
33 | |||
34 | |||
35 | pkg_prerm_${PN} () { | ||
36 | update-alternatives --remove bunzip2 bunzip2.${PN} | ||
37 | update-alternatives --remove bzcat bzcat.${PN} | ||
38 | } | ||
39 | |||
40 | PROVIDES_append_virtclass-native = " bzip2-full-native" | ||
41 | BBCLASSEXTEND = "native" | ||