summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash/bash_3.2.48.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/bash/bash_3.2.48.bb')
-rw-r--r--meta/recipes-extended/bash/bash_3.2.48.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-extended/bash/bash_3.2.48.bb b/meta/recipes-extended/bash/bash_3.2.48.bb
new file mode 100644
index 0000000000..ee563d626a
--- /dev/null
+++ b/meta/recipes-extended/bash/bash_3.2.48.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "An sh-compatible command language interpreter."
2HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
3SECTION = "base/shell"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=fd5d9bcabd8ed5a54a01ce8d183d592a"
7DEPENDS = "ncurses"
8
9PR = "r6"
10
11SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
12 http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-049;apply=yes;striplevel=0 \
13 http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-050;apply=yes;striplevel=0 \
14 http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-051;apply=yes;striplevel=0"
15
16inherit autotools gettext
17
18PARALLEL_MAKE = ""
19
20bindir = "/bin"
21sbindir = "/sbin"
22
23EXTRA_OECONF = "--with-ncurses"
24export CC_FOR_BUILD = "${BUILD_CC}"
25
26do_configure () {
27 gnu-configize
28 oe_runconf
29}
30
31pkg_postinst () {
32 touch $D${sysconfdir}/shells
33 grep -q "bin/bash" $D${sysconfdir}/shells || echo /bin/bash >> $D${sysconfdir}/shells
34 grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
35}