summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash/bash_3.2.48.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/bash/bash_3.2.48.bb')
-rw-r--r--meta/recipes-extended/bash/bash_3.2.48.bb31
1 files changed, 2 insertions, 29 deletions
diff --git a/meta/recipes-extended/bash/bash_3.2.48.bb b/meta/recipes-extended/bash/bash_3.2.48.bb
index 509d7a092e..828d629469 100644
--- a/meta/recipes-extended/bash/bash_3.2.48.bb
+++ b/meta/recipes-extended/bash/bash_3.2.48.bb
@@ -1,12 +1,9 @@
1DESCRIPTION = "An sh-compatible command language interpreter." 1require bash.inc
2HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
3SECTION = "base/shell"
4 2
5LICENSE = "GPLv2+" 3LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=fd5d9bcabd8ed5a54a01ce8d183d592a" 4LIC_FILES_CHKSUM = "file://COPYING;md5=fd5d9bcabd8ed5a54a01ce8d183d592a"
7DEPENDS = "ncurses"
8 5
9PR = "r10" 6PR = "r11"
10 7
11SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz;name=tarball \ 8SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz;name=tarball \
12 ${GNU_MIRROR}/bash/bash-3.2-patches/bash32-049;apply=yes;striplevel=0;name=patch001 \ 9 ${GNU_MIRROR}/bash/bash-3.2-patches/bash32-049;apply=yes;striplevel=0;name=patch001 \
@@ -24,27 +21,3 @@ SRC_URI[patch003.sha256sum] = "354886097cd95b4def77028f32ee01e2e088d58a98184fede
24 21
25SRC_URI[md5sum] = "338dcf975a93640bb3eaa843ca42e3f8" 22SRC_URI[md5sum] = "338dcf975a93640bb3eaa843ca42e3f8"
26SRC_URI[sha256sum] = "128d281bd5682ba5f6953122915da71976357d7a76490d266c9173b1d0426348" 23SRC_URI[sha256sum] = "128d281bd5682ba5f6953122915da71976357d7a76490d266c9173b1d0426348"
27
28inherit autotools gettext
29
30PARALLEL_MAKE = ""
31
32bindir = "/bin"
33sbindir = "/sbin"
34
35EXTRA_OECONF = "--with-ncurses"
36export CC_FOR_BUILD = "${BUILD_CC}"
37
38export AUTOHEADER = "true"
39
40do_configure_prepend () {
41 if [ ! -e acinclude.m4 ]; then
42 cat aclocal.m4 > acinclude.m4
43 fi
44}
45
46pkg_postinst_${PN} () {
47 touch $D${sysconfdir}/shells
48 grep -q "bin/bash" $D${sysconfdir}/shells || echo /bin/bash >> $D${sysconfdir}/shells
49 grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
50}