summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at/at_3.1.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/at/at_3.1.18.bb')
-rw-r--r--meta/recipes-extended/at/at_3.1.18.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-extended/at/at_3.1.18.bb b/meta/recipes-extended/at/at_3.1.18.bb
new file mode 100644
index 0000000000..e83ea32825
--- /dev/null
+++ b/meta/recipes-extended/at/at_3.1.18.bb
@@ -0,0 +1,69 @@
1SUMMARY = "Delayed job execution and batch processing"
2DESCRIPTION = "At allows for commands to be run at a particular time. Batch will execute commands when \
3the system load levels drop to a particular level."
4SECTION = "base"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
7DEPENDS = "flex flex-native \
8 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
9
10RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_DEPS}', '', d)} \
11"
12
13PAM_DEPS = "libpam libpam-runtime pam-plugin-env pam-plugin-limits"
14
15RCONFLICTS_${PN} = "atd"
16RREPLACES_${PN} = "atd"
17
18SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz;subdir=${BP} \
19 file://fix_parallel_build_error.patch \
20 file://posixtm.c \
21 file://posixtm.h \
22 file://file_replacement_with_gplv2.patch \
23 file://atd.init \
24 file://atd.service \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
26 file://makefile-fix-parallel.patch \
27 file://0001-remove-glibc-assumption.patch \
28 "
29
30PAM_SRC_URI = "file://pam.conf.patch \
31 file://configure-add-enable-pam.patch"
32
33SRC_URI[md5sum] = "f67a7aab557cd5b4a1311079a08acebe"
34SRC_URI[sha256sum] = "dbd5c8cb8edd53ef467363c3af0391c08769f1dbbd4d5002c59a4cd4cac11d52"
35
36EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \
37 --with-daemon_username=root \
38 --with-daemon_groupname=root \
39 --with-jobdir=/var/spool/at/jobs \
40 --with-atspool=/var/spool/at/spool \
41 ac_cv_header_security_pam_appl_h=${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'yes', 'no', d)} "
42
43inherit autotools-brokensep systemd update-rc.d
44
45INITSCRIPT_NAME = "atd"
46INITSCRIPT_PARAMS = "defaults"
47
48SYSTEMD_SERVICE_${PN} = "atd.service"
49
50copy_sources() {
51 cp -f ${WORKDIR}/posixtm.[ch] ${S}
52}
53do_patch[postfuncs] += "copy_sources"
54
55do_install () {
56 oe_runmake -e "IROOT=${D}" install
57
58 install -d ${D}${sysconfdir}/init.d
59 install -m 0755 ${WORKDIR}/atd.init ${D}${sysconfdir}/init.d/atd
60
61 # install systemd unit files
62 install -d ${D}${systemd_unitdir}/system
63 install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system
64 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/atd.service
65
66 if [ "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" = "pam" ]; then
67 install -D -m 0644 ${WORKDIR}/${BP}/pam.conf ${D}${sysconfdir}/pam.d/atd
68 fi
69}