summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at/at_3.1.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/at/at_3.1.15.bb')
-rw-r--r--meta/recipes-extended/at/at_3.1.15.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-extended/at/at_3.1.15.bb b/meta/recipes-extended/at/at_3.1.15.bb
new file mode 100644
index 0000000000..0c37d6d912
--- /dev/null
+++ b/meta/recipes-extended/at/at_3.1.15.bb
@@ -0,0 +1,67 @@
1SUMMARY = "Delayed job execution and batch processing"
2DESCRIPTION = "At allows for commands to be run at a particular time. Batch will execute commands when \
3the system load levels drop to a particular level."
4SECTION = "base"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
7DEPENDS = "flex flex-native \
8 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
9
10RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_DEPS}', '', d)} \
11"
12
13PAM_DEPS = "libpam libpam-runtime pam-plugin-env pam-plugin-limits"
14
15RCONFLICTS_${PN} = "atd"
16RREPLACES_${PN} = "atd"
17
18SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \
19 file://fix_parallel_build_error.patch \
20 file://posixtm.c \
21 file://posixtm.h \
22 file://file_replacement_with_gplv2.patch \
23 file://atd.init \
24 file://atd.service \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
26
27PAM_SRC_URI = "file://pam.conf.patch \
28 file://configure-add-enable-pam.patch"
29
30SRC_URI[md5sum] = "f0f96db22e3a174b53ce4beeeb848839"
31SRC_URI[sha256sum] = "03a84f5293d5a95ef4231b7faf5578f141f0c76a2b304dd655bc7e90e97bf7fc"
32
33EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \
34 --with-daemon_username=root \
35 --with-daemon_groupname=root \
36 --with-jobdir=/var/spool/at/jobs \
37 --with-atspool=/var/spool/at/spool \
38 ac_cv_header_security_pam_appl_h=${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'yes', 'no', d)} "
39
40inherit autotools-brokensep systemd update-rc.d
41
42INITSCRIPT_NAME = "atd"
43INITSCRIPT_PARAMS = "defaults"
44
45SYSTEMD_SERVICE_${PN} = "atd.service"
46
47PARALLEL_MAKE = ""
48
49do_compile_prepend () {
50 cp -f ${WORKDIR}/posixtm.[ch] ${S}
51}
52
53do_install () {
54 oe_runmake -e "IROOT=${D}" install
55
56 install -d ${D}${sysconfdir}/init.d
57 install -m 0755 ${WORKDIR}/atd.init ${D}${sysconfdir}/init.d/atd
58
59 # install systemd unit files
60 install -d ${D}${systemd_unitdir}/system
61 install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system
62 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/atd.service
63
64 if [ "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" = "pam" ]; then
65 install -D -m 0644 ${WORKDIR}/${BP}/pam.conf ${D}${sysconfdir}/pam.d/atd
66 fi
67}