diff options
Diffstat (limited to 'meta/recipes-extended/at/at_3.1.15.bb')
-rw-r--r-- | meta/recipes-extended/at/at_3.1.15.bb | 68 |
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/recipes-extended/at/at_3.1.15.bb b/meta/recipes-extended/at/at_3.1.15.bb new file mode 100644 index 0000000000..a465a76324 --- /dev/null +++ b/meta/recipes-extended/at/at_3.1.15.bb | |||
@@ -0,0 +1,68 @@ | |||
1 | SUMMARY = "Delayed job execution and batch processing" | ||
2 | DESCRIPTION = "At allows for commands to be run at a particular time. Batch will execute commands when \ | ||
3 | the system load levels drop to a particular level." | ||
4 | SECTION = "base" | ||
5 | LICENSE = "GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" | ||
7 | DEPENDS = "flex flex-native \ | ||
8 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" | ||
9 | |||
10 | VIRTUAL-RUNTIME_initscripts ?= "initscripts" | ||
11 | RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_DEPS}', '', d)} \ | ||
12 | ${VIRTUAL-RUNTIME_initscripts} \ | ||
13 | " | ||
14 | |||
15 | PAM_DEPS = "libpam libpam-runtime pam-plugin-env pam-plugin-limits" | ||
16 | |||
17 | RCONFLICTS_${PN} = "atd" | ||
18 | RREPLACES_${PN} = "atd" | ||
19 | |||
20 | SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \ | ||
21 | file://fix_parallel_build_error.patch \ | ||
22 | file://posixtm.c \ | ||
23 | file://posixtm.h \ | ||
24 | file://file_replacement_with_gplv2.patch \ | ||
25 | file://S99at \ | ||
26 | file://atd.service \ | ||
27 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}" | ||
28 | |||
29 | PAM_SRC_URI = "file://pam.conf.patch \ | ||
30 | file://configure-add-enable-pam.patch" | ||
31 | |||
32 | SRC_URI[md5sum] = "f0f96db22e3a174b53ce4beeeb848839" | ||
33 | SRC_URI[sha256sum] = "03a84f5293d5a95ef4231b7faf5578f141f0c76a2b304dd655bc7e90e97bf7fc" | ||
34 | |||
35 | EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \ | ||
36 | --with-daemon_username=root \ | ||
37 | --with-daemon_groupname=root \ | ||
38 | --with-jobdir=/var/spool/at/jobs \ | ||
39 | --with-atspool=/var/spool/at/spool \ | ||
40 | ac_cv_header_security_pam_appl_h=${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'yes', 'no', d)} " | ||
41 | |||
42 | inherit autotools-brokensep systemd | ||
43 | |||
44 | SYSTEMD_SERVICE_${PN} = "atd.service" | ||
45 | |||
46 | PARALLEL_MAKE = "" | ||
47 | |||
48 | do_compile_prepend () { | ||
49 | cp -f ${WORKDIR}/posixtm.[ch] ${S} | ||
50 | } | ||
51 | |||
52 | do_install () { | ||
53 | oe_runmake -e "IROOT=${D}" install | ||
54 | |||
55 | install -d ${D}${sysconfdir}/init.d | ||
56 | install -d ${D}${sysconfdir}/rcS.d | ||
57 | install -m 0755 ${WORKDIR}/S99at ${D}${sysconfdir}/init.d/atd | ||
58 | ln -sf ../init.d/atd ${D}${sysconfdir}/rcS.d/S99at | ||
59 | |||
60 | # install systemd unit files | ||
61 | install -d ${D}${systemd_unitdir}/system | ||
62 | install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system | ||
63 | sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/atd.service | ||
64 | |||
65 | if [ "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" = "pam" ]; then | ||
66 | install -D -m 0644 ${WORKDIR}/${BP}/pam.conf ${D}${sysconfdir}/pam.d/atd | ||
67 | fi | ||
68 | } | ||