summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at/at_3.1.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/at/at_3.1.12.bb')
-rw-r--r--meta/recipes-extended/at/at_3.1.12.bb32
1 files changed, 26 insertions, 6 deletions
diff --git a/meta/recipes-extended/at/at_3.1.12.bb b/meta/recipes-extended/at/at_3.1.12.bb
index 605179b21f..bec09b6958 100644
--- a/meta/recipes-extended/at/at_3.1.12.bb
+++ b/meta/recipes-extended/at/at_3.1.12.bb
@@ -1,19 +1,39 @@
1require at.inc 1DESCRIPTION = "Delayed job execution and batch processing"
2 2SECTION = "base"
3LICENSE="GPLv2+" 3LICENSE="GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" 4LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
5 5DEPENDS = "flex libpam initscripts"
6PR = "r1" 6RCONFLICTS_${PN} = "atd"
7RREPLACES_${PN} = "atd"
8PR = "r2"
7 9
8SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \ 10SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \
9 file://configure.patch \ 11 file://configure.patch \
10 file://nonrootinstall.patch \ 12 file://nonrootinstall.patch \
11 file://use-ldflags.patch \ 13 file://use-ldflags.patch \
14 file://fix_parallel_build_error.patch \
12 file://posixtm.c \ 15 file://posixtm.c \
13 file://posixtm.h \ 16 file://posixtm.h \
14 file://file_replacement_with_gplv2.patch" 17 file://file_replacement_with_gplv2.patch \
18 file://S99at"
19
20EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \
21 --with-daemon_username=root \
22 --with-daemon_groupname=root \
23 --with-jobdir=/var/spool/cron/atjobs \
24 --with-atspool=/var/spool/cron/atspool"
25
26inherit autotools
15 27
16do_compile_prepend () { 28do_compile_prepend () {
17 mv ${WORKDIR}/posixtm.[ch] ${S} 29 cp -f ${WORKDIR}/posixtm.[ch] ${S}
18} 30}
19 31
32do_install () {
33 oe_runmake "IROOT=${D}" install
34
35 install -d ${D}${sysconfdir}/init.d
36 install -d ${D}${sysconfdir}/rcS.d
37 install -m 0755 ${WORKDIR}/S99at ${D}${sysconfdir}/init.d/at
38 ln -sf ../init.d/at ${D}${sysconfdir}/rcS.d/S99at
39}