summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/acpica/acpica_20210105.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/acpica/acpica_20210105.bb')
-rw-r--r--meta/recipes-extended/acpica/acpica_20210105.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/acpica/acpica_20210105.bb b/meta/recipes-extended/acpica/acpica_20210105.bb
new file mode 100644
index 0000000000..48b560db53
--- /dev/null
+++ b/meta/recipes-extended/acpica/acpica_20210105.bb
@@ -0,0 +1,49 @@
1SUMMARY = "ACPICA tools for the development and debug of ACPI tables"
2DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \
3OS-independent reference implementation of the Advanced Configuration and \
4Power Interface Specification (ACPI). ACPICA code contains those portions of \
5ACPI meant to be directly integrated into the host OS as a kernel-resident \
6subsystem, and a small set of tools to assist in developing and debugging \
7ACPI tables."
8
9HOMEPAGE = "http://www.acpica.org/"
10SECTION = "console/tools"
11
12LICENSE = "Intel | BSD | GPLv2"
13LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=c33ce358fdcd142684e41e336b7992e8"
14
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
16
17DEPENDS = "m4-native flex-native bison-native"
18
19SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz"
20SRC_URI[sha256sum] = "a9be7b749025e60f93fde2fe531bfe0d84a33641d3e0c9b0f6049f996dbb1ff8"
21
22UPSTREAM_CHECK_URI = "https://acpica.org/downloads"
23
24S = "${WORKDIR}/acpica-unix-${PV}"
25
26inherit update-alternatives
27
28ALTERNATIVE_PRIORITY = "100"
29ALTERNATIVE_${PN} = "acpixtract acpidump"
30
31EXTRA_OEMAKE = "CC='${CC}' \
32 OPT_CFLAGS=-Wall \
33 DESTDIR=${D} \
34 PREFIX=${prefix} \
35 INSTALLDIR=${bindir} \
36 INSTALLFLAGS= \
37 "
38
39do_install() {
40 oe_runmake install
41}
42
43# iasl*.bb is a subset of this recipe, so RREPLACE it
44PROVIDES = "iasl"
45RPROVIDES_${PN} += "iasl"
46RREPLACES_${PN} += "iasl"
47RCONFLICTS_${PN} += "iasl"
48
49BBCLASSEXTEND = "native"