summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/xmlto/xmlto_0.0.28.bb')
-rw-r--r--meta/recipes-devtools/xmlto/xmlto_0.0.28.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb b/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb
new file mode 100644
index 0000000000..514f527ac7
--- /dev/null
+++ b/meta/recipes-devtools/xmlto/xmlto_0.0.28.bb
@@ -0,0 +1,38 @@
1SUMMARY = "A shell-script tool for converting XML files to various formats"
2HOMEPAGE = "https://fedorahosted.org/xmlto/"
3SECTION = "docs/xmlto"
4LICENSE = "GPLv2"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
7
8SRC_URI = "https://fedorahosted.org/releases/x/m/xmlto/xmlto-${PV}.tar.gz \
9 file://configure.in-drop-the-test-of-xmllint-and-xsltproc.patch \
10 file://catalog.xml \
11"
12SRC_URI[md5sum] = "a1fefad9d83499a15576768f60f847c6"
13SRC_URI[sha256sum] = "2f986b7c9a0e9ac6728147668e776d405465284e13c74d4146c9cbc51fd8aad3"
14
15inherit autotools
16
17# xmlto needs getopt/xmllint/xsltproc/bash at runtime
18RDEPENDS_${PN} = "docbook-xml-dtd4 \
19 docbook-xsl-stylesheets \
20 util-linux \
21 libxml2 \
22 bash \
23"
24RDEPENDS_${PN}_append_class-target = " \
25 libxslt-bin \
26"
27
28BBCLASSEXTEND = "native"
29
30EXTRA_OECONF_append = " XMLLINT=xmllint XSLTPROC=xsltproc"
31
32do_install_append() {
33 install -d ${D}${sysconfdir}/xml/
34 install -m 755 ${WORKDIR}/catalog.xml ${D}${sysconfdir}/xml/catalog.xml
35 create_wrapper ${D}/${bindir}/xmlto XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml
36}
37
38do_populate_sysroot[rdeptask] = "do_populate_sysroot"