summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/unifdef/unifdef-native_2.6.18+git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/unifdef/unifdef-native_2.6.18+git.bb')
-rw-r--r--meta/recipes-devtools/unifdef/unifdef-native_2.6.18+git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/unifdef/unifdef-native_2.6.18+git.bb b/meta/recipes-devtools/unifdef/unifdef-native_2.6.18+git.bb
new file mode 100644
index 0000000000..d879782b29
--- /dev/null
+++ b/meta/recipes-devtools/unifdef/unifdef-native_2.6.18+git.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "Kernel header preprocessor"
2SECTION = "devel"
3LICENSE = "GPL"
4
5SRC_URI = "file://unifdef.c"
6
7inherit native
8
9do_compile() {
10 ${CC} ${CFLAGS} ${LDFLAGS} -o unifdef ${WORKDIR}/unifdef.c
11}
12
13do_install() {
14 install -d ${D}${bindir}
15 install -m 0755 unifdef ${D}${bindir}
16}
17