diff options
Diffstat (limited to 'meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb')
-rw-r--r-- | meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb | 71 |
1 files changed, 71 insertions, 0 deletions
diff --git a/meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb b/meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb new file mode 100644 index 0000000000..ecba4525a2 --- /dev/null +++ b/meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb | |||
@@ -0,0 +1,71 @@ | |||
1 | DESCRIPTION = "Userspace NFS server" | ||
2 | SECTION = "console/network" | ||
3 | LICENSE = "GPLv2+" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" | ||
5 | |||
6 | PR = "r0" | ||
7 | |||
8 | SRC_URI = "ftp://linux.mathematik.tu-darmstadt.de/pub/linux/oldstuff/people/okir/nfs-server-${PV}.tar.gz \ | ||
9 | file://001-2.2b47-2.2b51.patch \ | ||
10 | file://002-destdir.patch \ | ||
11 | file://003-manpages.patch \ | ||
12 | file://004-strsignal.patch \ | ||
13 | file://005-sys-time.patch \ | ||
14 | file://006-reiserfs.patch \ | ||
15 | file://007-map.patch \ | ||
16 | file://008-configure.patch \ | ||
17 | file://009-multirw.patch \ | ||
18 | file://010-realpath.patch \ | ||
19 | file://011-fno-strict-aliasing.patch \ | ||
20 | file://012-nostrip.patch \ | ||
21 | file://013-mntpathlen.patch \ | ||
22 | file://014-uninitialized.patch \ | ||
23 | file://015-setattr.patch \ | ||
24 | file://016-makefile.in.patch \ | ||
25 | file://017-wrs-dynamic-rpc.patch \ | ||
26 | file://018-remove-tcp-wrappers.patch \ | ||
27 | file://019-pid-before-fork.patch \ | ||
28 | file://020-undefined-chmod-fix.patch \ | ||
29 | file://021-nolibwrap.patch \ | ||
30 | file://022-add-close-on-exec-descriptors.patch \ | ||
31 | " | ||
32 | |||
33 | SRC_URI[md5sum] = "79a29fe9f79b2f3241d4915767b8c511" | ||
34 | SRC_URI[sha256sum] = "7eeaf3cf0b9d96167a5ba03bf1046e39b4585de1339a55b285e673c06ba415cb" | ||
35 | |||
36 | S = "${WORKDIR}/nfs-server-${PV}/" | ||
37 | |||
38 | inherit autotools | ||
39 | |||
40 | BBCLASSEXTEND = "native nativesdk" | ||
41 | |||
42 | CFLAGS = "-fPIE -fstack-protector-all" | ||
43 | LDFLAGS = "-pie" | ||
44 | |||
45 | EXTRA_OECONF = "--enable-ugid-dynamic \ | ||
46 | --enable-ugid-nis \ | ||
47 | --enable-host-access \ | ||
48 | --with-exports-uid=0 \ | ||
49 | --with-exports-gid=0 \ | ||
50 | --enable-mount-logging \ | ||
51 | --with-devtab=${DESTDIR}${base_prefix}/var/lib/nfs/devtab \ | ||
52 | " | ||
53 | |||
54 | do_configure_prepend () { | ||
55 | # Remove pregenerated xdr functions. They use long | ||
56 | # instead of u32, which produces incorrect code on | ||
57 | # 64-bit architectures: | ||
58 | rm -f *_xdr.c | ||
59 | |||
60 | mv aclocal.m4 acinclude.m4 | ||
61 | } | ||
62 | |||
63 | # This recipe is intended for -native and -nativesdk builds only, | ||
64 | # not target installs: | ||
65 | python __anonymous () { | ||
66 | import re | ||
67 | |||
68 | pn = bb.data.getVar("PN", d, 1) | ||
69 | if not pn.endswith('-native') and not pn.endswith('-nativesdk'): | ||
70 | raise bb.parse.SkipPackage("unfs-server is intended for native/nativesdk builds only") | ||
71 | } | ||