summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beta47.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beta47.bb')
-rw-r--r--meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beta47.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beta47.bb b/meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beta47.bb
new file mode 100644
index 0000000000..8ed2e33f95
--- /dev/null
+++ b/meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beta47.bb
@@ -0,0 +1,75 @@
1DESCRIPTION = "Userspace NFS server"
2SECTION = "console/network"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
5
6RDEPENDS_${PN} = "pseudo"
7RDEPENDS_${PN}_virtclass-native = "pseudo-native"
8RDEPENDS_${PN}_virtclass-nativesdk = "pseudo-nativesdk"
9BASEPV = "2.2beta47"
10PR = "r0"
11
12SRC_URI = "ftp://linux.mathematik.tu-darmstadt.de/pub/linux/oldstuff/people/okir/nfs-server-${BASEPV}.tar.gz \
13 file://001-2.2b47-2.2b51.patch \
14 file://002-destdir.patch \
15 file://003-manpages.patch \
16 file://004-strsignal.patch \
17 file://005-sys-time.patch \
18 file://006-reiserfs.patch \
19 file://007-map.patch \
20 file://008-configure.patch \
21 file://009-multirw.patch \
22 file://010-realpath.patch \
23 file://011-fno-strict-aliasing.patch \
24 file://012-nostrip.patch \
25 file://013-mntpathlen.patch \
26 file://014-uninitialized.patch \
27 file://015-setattr.patch \
28 file://016-makefile.in.patch \
29 file://017-wrs-dynamic-rpc.patch \
30 file://018-remove-tcp-wrappers.patch \
31 file://019-pid-before-fork.patch \
32 file://020-undefined-chmod-fix.patch \
33 file://021-nolibwrap.patch \
34 file://022-add-close-on-exec-descriptors.patch \
35 "
36
37SRC_URI[md5sum] = "79a29fe9f79b2f3241d4915767b8c511"
38SRC_URI[sha256sum] = "7eeaf3cf0b9d96167a5ba03bf1046e39b4585de1339a55b285e673c06ba415cb"
39
40S = "${WORKDIR}/nfs-server-${BASEPV}/"
41
42inherit autotools
43
44BBCLASSEXTEND = "native nativesdk"
45
46CFLAGS = "-fPIE -fstack-protector-all"
47LDFLAGS = "-pie"
48
49EXTRA_OECONF = "--enable-ugid-dynamic \
50 --enable-ugid-nis \
51 --enable-host-access \
52 --with-exports-uid=0 \
53 --with-exports-gid=0 \
54 --enable-mount-logging \
55 --with-devtab=${DESTDIR}${base_prefix}/var/lib/nfs/devtab \
56 "
57
58do_configure_prepend () {
59 # Remove pregenerated xdr functions. They use long
60 # instead of u32, which produces incorrect code on
61 # 64-bit architectures:
62 rm -f *_xdr.c
63
64 mv aclocal.m4 acinclude.m4
65}
66
67# This recipe is intended for -native and -nativesdk builds only,
68# not target installs:
69python __anonymous () {
70 import re
71
72 pn = bb.data.getVar("PN", d, 1)
73 if not pn.endswith('-native') and not pn.endswith('-nativesdk'):
74 raise bb.parse.SkipPackage("unfs-server is intended for native/nativesdk builds only")
75}