summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beat47.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beat47.bb')
-rw-r--r--meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beat47.bb74
1 files changed, 74 insertions, 0 deletions
diff --git a/meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beat47.bb b/meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beat47.bb
new file mode 100644
index 0000000000..86ef300b09
--- /dev/null
+++ b/meta/recipes-devtools/unfs-server/unfs-server_2.1+2.2beat47.bb
@@ -0,0 +1,74 @@
1DESCRIPTION = "Userspace NFS server"
2SECTION = "console/network"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
5
6RDEPENDS_${PN} = "pseudo"
7RDEPENDS_${PN}_virtclass-native = "pseudo-native"
8RDEPENDS_${PN}_virtclass-nativesdk = "pseudo-nativesdk"
9PR = "r2"
10
11SRC_URI = "ftp://linux.mathematik.tu-darmstadt.de/pub/linux/oldstuff/people/okir/nfs-server-${PV}.tar.gz \
12 file://001-2.2b47-2.2b51.patch \
13 file://002-destdir.patch \
14 file://003-manpages.patch \
15 file://004-strsignal.patch \
16 file://005-sys-time.patch \
17 file://006-reiserfs.patch \
18 file://007-map.patch \
19 file://008-configure.patch \
20 file://009-multirw.patch \
21 file://010-realpath.patch \
22 file://011-fno-strict-aliasing.patch \
23 file://012-nostrip.patch \
24 file://013-mntpathlen.patch \
25 file://014-uninitialized.patch \
26 file://015-setattr.patch \
27 file://016-makefile.in.patch \
28 file://017-wrs-dynamic-rpc.patch \
29 file://018-remove-tcp-wrappers.patch \
30 file://019-pid-before-fork.patch \
31 file://020-undefined-chmod-fix.patch \
32 file://021-nolibwrap.patch \
33 file://022-add-close-on-exec-descriptors.patch \
34 "
35
36SRC_URI[md5sum] = "79a29fe9f79b2f3241d4915767b8c511"
37SRC_URI[sha256sum] = "7eeaf3cf0b9d96167a5ba03bf1046e39b4585de1339a55b285e673c06ba415cb"
38
39S = "${WORKDIR}/nfs-server-${PV}/"
40
41inherit autotools
42
43BBCLASSEXTEND = "native nativesdk"
44
45CFLAGS = "-fPIE -fstack-protector-all"
46LDFLAGS = "-pie"
47
48EXTRA_OECONF = "--enable-ugid-dynamic \
49 --enable-ugid-nis \
50 --enable-host-access \
51 --with-exports-uid=0 \
52 --with-exports-gid=0 \
53 --enable-mount-logging \
54 --with-devtab=${DESTDIR}${base_prefix}/var/lib/nfs/devtab \
55 "
56
57do_configure_prepend () {
58 # Remove pregenerated xdr functions. They use long
59 # instead of u32, which produces incorrect code on
60 # 64-bit architectures:
61 rm -f *_xdr.c
62
63 mv aclocal.m4 acinclude.m4
64}
65
66# This recipe is intended for -native and -nativesdk builds only,
67# not target installs:
68python __anonymous () {
69 import re
70
71 pn = bb.data.getVar("PN", d, 1)
72 if not pn.endswith('-native') and not pn.endswith('-nativesdk'):
73 raise bb.parse.SkipPackage("unfs-server is intended for native/nativesdk builds only")
74}