diff options
Diffstat (limited to 'meta/recipes-devtools/ubootchart/ubootchart_svn.bb')
-rw-r--r-- | meta/recipes-devtools/ubootchart/ubootchart_svn.bb | 39 |
1 files changed, 0 insertions, 39 deletions
diff --git a/meta/recipes-devtools/ubootchart/ubootchart_svn.bb b/meta/recipes-devtools/ubootchart/ubootchart_svn.bb deleted file mode 100644 index b13755e855..0000000000 --- a/meta/recipes-devtools/ubootchart/ubootchart_svn.bb +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | SUMMARY = "A boot profiling tool" | ||
2 | HOMEPAGE = "http://code.google.com/p/ubootchart/" | ||
3 | LICENSE = "GPLv3" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=8f0e2cd40e05189ec81232da84bd6e1a" | ||
5 | SRCREV = "12" | ||
6 | PV = "0.0+r${SRCPV}" | ||
7 | PR = "r6" | ||
8 | |||
9 | #RRECOMMENDS_${PN} = "acct" | ||
10 | |||
11 | SRC_URI = "svn://ubootchart.googlecode.com/svn/;protocol=http;module=trunk \ | ||
12 | file://sysvinit.patch;striplevel=0 \ | ||
13 | file://ubootchart-stop \ | ||
14 | file://ubootchart.desktop" | ||
15 | |||
16 | S = "${WORKDIR}/trunk" | ||
17 | |||
18 | inherit update-alternatives | ||
19 | |||
20 | ALTERNATIVE_${PN} = "init" | ||
21 | ALTERNATIVE_TARGET[init] = "${base_sbindir}/ubootchartd" | ||
22 | ALTERNATIVE_LINK_NAME[init] = "${base_sbindir}/init" | ||
23 | ALTERNATIVE_PRIORITY = "70" | ||
24 | |||
25 | do_compile() { | ||
26 | ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin | ||
27 | } | ||
28 | |||
29 | do_install() { | ||
30 | install -m 0755 -d ${D}${base_sbindir} ${D}${sysconfdir}/ubootchart ${D}${datadir}/applications | ||
31 | install -m 0755 ${S}/ubootchartd_bin ${D}${base_sbindir} | ||
32 | install -m 0755 ${S}/ubootchartd ${D}${base_sbindir} | ||
33 | install -m 0644 ${S}/ubootchart.conf ${D}${sysconfdir}/ubootchart | ||
34 | install -m 0755 ${S}/start.sh ${D}${sysconfdir}/ubootchart | ||
35 | install -m 0755 ${S}/finish.sh ${D}${sysconfdir}/ubootchart | ||
36 | |||
37 | install -m 0755 ${WORKDIR}/ubootchart-stop ${D}${base_sbindir} | ||
38 | install -m 0644 ${WORKDIR}/ubootchart.desktop ${D}${datadir}/applications | ||
39 | } | ||