summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ubootchart/ubootchart_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ubootchart/ubootchart_svn.bb')
-rw-r--r--meta/recipes-devtools/ubootchart/ubootchart_svn.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ubootchart/ubootchart_svn.bb b/meta/recipes-devtools/ubootchart/ubootchart_svn.bb
new file mode 100644
index 0000000000..cd292b6943
--- /dev/null
+++ b/meta/recipes-devtools/ubootchart/ubootchart_svn.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "A boot profiling tool"
2HOMEPAGE = "http://code.google.com/p/ubootchart/"
3LICENSE = "GPLv3"
4PV = "0.0+r${SRCREV}"
5PR = "r4"
6
7#RRECOMMENDS = "acct"
8
9SRC_URI = "svn://ubootchart.googlecode.com/svn/;proto=http;module=trunk \
10 file://sysvinit.patch;patch=1;pnum=0 \
11 file://ubootchart-stop \
12 file://ubootchart.desktop"
13
14S = "${WORKDIR}/trunk"
15
16inherit update-alternatives
17
18ALTERNATIVE_NAME = "init"
19ALTERNATIVE_LINK = "${base_sbindir}/init"
20ALTERNATIVE_PATH = "${base_sbindir}/ubootchartd"
21ALTERNATIVE_PRIORITY = "70"
22
23do_compile() {
24 ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
25}
26
27do_install() {
28 install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart ${D}/usr/share/applications
29 install -m 0755 ${S}/ubootchartd_bin ${D}/sbin
30 install -m 0755 ${S}/ubootchartd ${D}/sbin
31 install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart
32 install -m 0755 ${S}/start.sh ${D}/etc/ubootchart
33 install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart
34
35 install -m 0755 ${WORKDIR}/ubootchart-stop ${D}/sbin
36 install -m 0644 ${WORKDIR}/ubootchart.desktop ${D}/usr/share/applications
37}