diff options
Diffstat (limited to 'meta/recipes-devtools/tcltk/tcl_8.6.9.bb')
-rw-r--r-- | meta/recipes-devtools/tcltk/tcl_8.6.9.bb | 101 |
1 files changed, 101 insertions, 0 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.9.bb b/meta/recipes-devtools/tcltk/tcl_8.6.9.bb new file mode 100644 index 0000000000..7f3778153a --- /dev/null +++ b/meta/recipes-devtools/tcltk/tcl_8.6.9.bb | |||
@@ -0,0 +1,101 @@ | |||
1 | SUMMARY = "Tool Command Language" | ||
2 | HOMEPAGE = "http://tcl.sourceforge.net" | ||
3 | SECTION = "devel/tcltk" | ||
4 | |||
5 | # http://www.tcl.tk/software/tcltk/license.html | ||
6 | LICENSE = "tcl & BSD-3-Clause" | ||
7 | LIC_FILES_CHKSUM = "file://../license.terms;md5=058f6229798281bbcac4239c788cfa38 \ | ||
8 | file://../compat/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ | ||
9 | file://../library/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ | ||
10 | file://../macosx/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ | ||
11 | file://../tests/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ | ||
12 | file://../win/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ | ||
13 | " | ||
14 | |||
15 | DEPENDS = "tcl-native zlib" | ||
16 | |||
17 | BASE_SRC_URI = "${SOURCEFORGE_MIRROR}/tcl/${BPN}${PV}-src.tar.gz \ | ||
18 | file://tcl-add-soname.patch" | ||
19 | SRC_URI = "${BASE_SRC_URI} \ | ||
20 | file://fix_non_native_build_issue.patch \ | ||
21 | file://fix_issue_with_old_distro_glibc.patch \ | ||
22 | file://no_packages.patch \ | ||
23 | file://tcl-remove-hardcoded-install-path.patch \ | ||
24 | file://alter-includedir.patch \ | ||
25 | file://run-ptest \ | ||
26 | " | ||
27 | SRC_URI[md5sum] = "aa0a121d95a0e7b73a036f26028538d4" | ||
28 | SRC_URI[sha256sum] = "ad0cd2de2c87b9ba8086b43957a0de3eb2eb565c7159d5f53ccbba3feb915f4e" | ||
29 | |||
30 | SRC_URI_class-native = "${BASE_SRC_URI}" | ||
31 | |||
32 | S = "${WORKDIR}/${BPN}${PV}/unix" | ||
33 | |||
34 | VER = "${PV}" | ||
35 | |||
36 | inherit autotools ptest binconfig | ||
37 | |||
38 | EXTRA_OECONF = "--enable-threads --disable-rpath --libdir=${libdir}" | ||
39 | |||
40 | do_compile_prepend() { | ||
41 | echo > ${S}/../compat/fixstrtod.c | ||
42 | } | ||
43 | |||
44 | do_install() { | ||
45 | autotools_do_install | ||
46 | oe_runmake 'DESTDIR=${D}' install-private-headers | ||
47 | ln -sf ./tclsh${VER} ${D}${bindir}/tclsh | ||
48 | ln -sf tclsh8.6 ${D}${bindir}/tclsh${VER} | ||
49 | sed -i "s;-L${B};-L${STAGING_LIBDIR};g" tclConfig.sh | ||
50 | sed -i "s;'${WORKDIR};'${STAGING_INCDIR};g" tclConfig.sh | ||
51 | install -d ${D}${bindir_crossscripts} | ||
52 | install -m 0755 tclConfig.sh ${D}${bindir_crossscripts} | ||
53 | install -m 0755 tclConfig.sh ${D}${libdir} | ||
54 | for dir in compat generic unix; do | ||
55 | install -d ${D}${includedir}/${BPN}${VER}/$dir | ||
56 | install -m 0644 ${S}/../$dir/*.h ${D}${includedir}/${BPN}${VER}/$dir/ | ||
57 | done | ||
58 | } | ||
59 | |||
60 | SYSROOT_DIRS += "${bindir_crossscripts}" | ||
61 | |||
62 | PACKAGES =+ "tcl-lib" | ||
63 | FILES_tcl-lib = "${libdir}/libtcl8.6.so.*" | ||
64 | FILES_${PN} += "${libdir}/tcl${VER} ${libdir}/tcl8.6 ${libdir}/tcl8" | ||
65 | FILES_${PN}-dev += "${libdir}/tclConfig.sh ${libdir}/tclooConfig.sh" | ||
66 | |||
67 | # isn't getting picked up by shlibs code | ||
68 | RDEPENDS_${PN} += "tcl-lib" | ||
69 | RDEPENDS_${PN}_class-native = "" | ||
70 | RDEPENDS_${PN}-ptest += "libgcc" | ||
71 | |||
72 | BBCLASSEXTEND = "native nativesdk" | ||
73 | |||
74 | do_compile_ptest() { | ||
75 | oe_runmake tcltest | ||
76 | } | ||
77 | |||
78 | do_install_ptest() { | ||
79 | cp ${B}/tcltest ${D}${PTEST_PATH} | ||
80 | cp -r ${S}/../library ${D}${PTEST_PATH} | ||
81 | cp -r ${S}/../tests ${D}${PTEST_PATH} | ||
82 | } | ||
83 | |||
84 | # Fix some paths that might be used by Tcl extensions | ||
85 | BINCONFIG_GLOB = "*Config.sh" | ||
86 | |||
87 | # Fix the path in sstate | ||
88 | SSTATE_SCAN_FILES += "*Config.sh" | ||
89 | |||
90 | # Cleanup host path from ${libdir}/tclConfig.sh and remove the | ||
91 | # ${bindir_crossscripts}/tclConfig.sh from target | ||
92 | PACKAGE_PREPROCESS_FUNCS += "tcl_package_preprocess" | ||
93 | tcl_package_preprocess() { | ||
94 | sed -i -e "s;${DEBUG_PREFIX_MAP};;g" \ | ||
95 | -e "s;-L${STAGING_LIBDIR};-L${libdir};g" \ | ||
96 | -e "s;${STAGING_INCDIR};${includedir};g" \ | ||
97 | -e "s;--sysroot=${RECIPE_SYSROOT};;g" \ | ||
98 | ${PKGD}${libdir}/tclConfig.sh | ||
99 | |||
100 | rm -f ${PKGD}${bindir_crossscripts}/tclConfig.sh | ||
101 | } | ||