summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk/tcl_8.6.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/tcltk/tcl_8.6.7.bb')
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.7.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.7.bb b/meta/recipes-devtools/tcltk/tcl_8.6.7.bb
index d00d2dc62b..dac73be6e7 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.7.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.7.bb
@@ -86,3 +86,16 @@ BINCONFIG_GLOB = "*Config.sh"
86 86
87# Fix the path in sstate 87# Fix the path in sstate
88SSTATE_SCAN_FILES += "*Config.sh" 88SSTATE_SCAN_FILES += "*Config.sh"
89
90# Cleanup host path from ${libdir}/tclConfig.sh and remove the
91# ${bindir_crossscripts}/tclConfig.sh from target
92PACKAGE_PREPROCESS_FUNCS += "tcl_package_preprocess"
93tcl_package_preprocess() {
94 sed -i -e "s;${DEBUG_PREFIX_MAP};;g" \
95 -e "s;-L${STAGING_LIBDIR};-L${libdir};g" \
96 -e "s;${STAGING_INCDIR};${includedir};g" \
97 -e "s;--sysroot=${RECIPE_SYSROOT};;g" \
98 ${PKGD}${libdir}/tclConfig.sh
99
100 rm -f ${PKGD}${bindir_crossscripts}/tclConfig.sh
101}