summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk/tcl_8.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/tcltk/tcl_8.6.1.bb')
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.1.bb26
1 files changed, 14 insertions, 12 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.1.bb b/meta/recipes-devtools/tcltk/tcl_8.6.1.bb
index e23970848f..f40475d2b5 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.1.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.1.bb
@@ -15,11 +15,12 @@ BASE_SRC_URI = "${SOURCEFORGE_MIRROR}/tcl/tcl${PV}-src.tar.gz \
15 file://tcl-add-soname.patch" 15 file://tcl-add-soname.patch"
16 16
17SRC_URI = "${BASE_SRC_URI} \ 17SRC_URI = "${BASE_SRC_URI} \
18 file://fix_non_native_build_issue.patch \ 18 file://fix_non_native_build_issue.patch \
19 file://fix_issue_with_old_distro_glibc.patch \ 19 file://fix_issue_with_old_distro_glibc.patch \
20 file://no_packages.patch \ 20 file://no_packages.patch \
21 file://tcl-remove-hardcoded-install-path.patch \ 21 file://tcl-remove-hardcoded-install-path.patch \
22 " 22 file://alter-includedir.patch \
23 "
23SRC_URI[md5sum] = "aae4b701ee527c6e4e1a6f9c7399882e" 24SRC_URI[md5sum] = "aae4b701ee527c6e4e1a6f9c7399882e"
24SRC_URI[sha256sum] = "16ee769248e64ba1cae6b4834fcc4e4edd7470d881410e8d58f7dd1434343514" 25SRC_URI[sha256sum] = "16ee769248e64ba1cae6b4834fcc4e4edd7470d881410e8d58f7dd1434343514"
25 26
@@ -27,6 +28,8 @@ SRC_URI_class-native = "${BASE_SRC_URI}"
27 28
28S = "${WORKDIR}/tcl${PV}/unix" 29S = "${WORKDIR}/tcl${PV}/unix"
29 30
31VER = "8.6"
32
30inherit autotools 33inherit autotools
31 34
32DEPENDS_class-native = "" 35DEPENDS_class-native = ""
@@ -43,9 +46,8 @@ do_compile_prepend() {
43} 46}
44 47
45do_install() { 48do_install() {
46 autotools_do_install 49 autotools_do_install install-private-headers
47 oe_libinstall -so libtcl8.6 ${D}${libdir} 50 ln -sf ./tclsh${VER} ${D}${bindir}/tclsh
48 ln -sf ./tclsh8.6 ${D}${bindir}/tclsh
49 sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh 51 sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh
50 sed -i "s,-L${libdir},-L=${libdir},g" tclConfig.sh 52 sed -i "s,-L${libdir},-L=${libdir},g" tclConfig.sh
51 sed -i "s,-I${includedir},-I=${includedir},g" tclConfig.sh 53 sed -i "s,-I${includedir},-I=${includedir},g" tclConfig.sh
@@ -54,8 +56,8 @@ do_install() {
54 cd .. 56 cd ..
55 for dir in compat generic unix 57 for dir in compat generic unix
56 do 58 do
57 install -d ${D}${includedir}/tcl${PV}/$dir 59 install -d ${D}${includedir}/${BPN}${VER}/$dir
58 install -m 0644 ${S}/../$dir/*.h ${D}${includedir}/tcl${PV}/$dir/ 60 install -m 0644 ${S}/../$dir/*.h ${D}${includedir}/${BPN}${VER}/$dir/
59 done 61 done
60} 62}
61 63
@@ -65,8 +67,8 @@ tcl_sysroot_preprocess () {
65} 67}
66 68
67PACKAGES =+ "tcl-lib" 69PACKAGES =+ "tcl-lib"
68FILES_tcl-lib = "${libdir}/libtcl8.6.so*" 70FILES_tcl-lib = "${libdir}/libtcl${VER}.so.*"
69FILES_${PN} += "${libdir}/tcl8.6 ${libdir}/tcl8" 71FILES_${PN} += "${libdir}/tcl${VER} ${libdir}/tcl8"
70FILES_${PN}-dev += "${libdir}/tclConfig.sh ${libdir}/tclooConfig.sh" 72FILES_${PN}-dev += "${libdir}/tclConfig.sh ${libdir}/tclooConfig.sh"
71 73
72# isn't getting picked up by shlibs code 74# isn't getting picked up by shlibs code