diff options
Diffstat (limited to 'meta/recipes-devtools/tcltk/tcl_8.5.8.bb')
-rw-r--r-- | meta/recipes-devtools/tcltk/tcl_8.5.8.bb | 62 |
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.5.8.bb b/meta/recipes-devtools/tcltk/tcl_8.5.8.bb new file mode 100644 index 0000000000..880340067c --- /dev/null +++ b/meta/recipes-devtools/tcltk/tcl_8.5.8.bb | |||
@@ -0,0 +1,62 @@ | |||
1 | DESCRIPTION = "Tool Command Language" | ||
2 | LICENSE = "tcl" | ||
3 | SECTION = "devel/tcltk" | ||
4 | HOMEPAGE = "http://tcl.sourceforge.net" | ||
5 | DEPENDS = "tcl-native" | ||
6 | LIC_CHKSUM_FILES = "file://../license.terms;md5=7b4d3c71b2d9a8c1b373609867975570 \ | ||
7 | file://../compat/license.terms;md5=7b4d3c71b2d9a8c1b373609867975570 \ | ||
8 | file://../library/license.terms;md5=7b4d3c71b2d9a8c1b373609867975570 \ | ||
9 | file://../macosx/license.terms;md5=7b4d3c71b2d9a8c1b373609867975570 \ | ||
10 | file://../tests/license.terms;md5=7b4d3c71b2d9a8c1b373609867975570 \ | ||
11 | file://../win/license.terms;md5=7b4d3c71b2d9a8c1b373609867975570 \ | ||
12 | " | ||
13 | |||
14 | PR = "r2" | ||
15 | |||
16 | BASE_SRC_URI = "${SOURCEFORGE_MIRROR}/tcl/tcl${PV}-src.tar.gz \ | ||
17 | file://tcl-add-soname.patch" | ||
18 | |||
19 | SRC_URI = "${BASE_SRC_URI} \ | ||
20 | file://fix_non_native_build_issue.patch" | ||
21 | |||
22 | SRC_URI_virtclass-native = "${BASE_SRC_URI}" | ||
23 | |||
24 | S = "${WORKDIR}/tcl${PV}/unix" | ||
25 | |||
26 | inherit autotools | ||
27 | |||
28 | DEPENDS_virtclass-native = "" | ||
29 | |||
30 | EXTRA_OECONF = "--enable-threads" | ||
31 | |||
32 | do_configure() { | ||
33 | gnu-configize | ||
34 | oe_runconf | ||
35 | } | ||
36 | |||
37 | do_compile_prepend() { | ||
38 | echo > ../compat/fixstrtod.c | ||
39 | } | ||
40 | |||
41 | do_install() { | ||
42 | autotools_do_install | ||
43 | oe_libinstall -so libtcl8.5 ${STAGING_LIBDIR} | ||
44 | ln -sf ./tclsh8.5 ${D}${bindir}/tclsh | ||
45 | sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh | ||
46 | sed -i "s,-L${libdir},," tclConfig.sh | ||
47 | install -d ${STAGING_BINDIR_CROSS}/ | ||
48 | install -m 0755 tclConfig.sh ${STAGING_BINDIR_CROSS} | ||
49 | cd .. | ||
50 | for dir in compat generic unix | ||
51 | do | ||
52 | install -d ${STAGING_INCDIR}/tcl${PV}/$dir | ||
53 | install -m 0644 $dir/*.h ${STAGING_INCDIR}/tcl${PV}/$dir/ | ||
54 | done | ||
55 | } | ||
56 | |||
57 | PACKAGES =+ "${PN}-lib" | ||
58 | FILES_${PN}-lib = "${libdir}/libtcl8.5.so.*" | ||
59 | FILES_${PN} += "${libdir}/tcl8.5" | ||
60 | FILES_${PN}-dev += "${libdir}/tclConfig.sh" | ||
61 | |||
62 | BBCLASSEXTEND = "native" | ||